Sorting the field names


#1

Is it possible to sort the list of field names? I imported my database from another application and the list of field names is quite long. It would be helpful if the names were sorted.


#2

Hi @frasej, yes, you should be able to sort the field labels:

  1. Launch STRIP for OS X or Windows
  2. Go to File menu -> Preferences (or STRIP menu -> Preferences on OS X)
  3. Use the drop-down control to sort labels by Name or Frequency of Use

In addition, under File menu -> Customize Labels (or STRIP menu -> Customize Labels on OS X) you can click on the name column header to sort by name.


#3

That’s what I thought, but it doesn’t work. I suspect there is something in the list of fields that is keeping it from sorting. When I go into “Customize Labels…”, the label names are sorted, but when I add a label to a record, they aren’t sorted and it starts out at “Password”. (I tried to send a picture but it wouldn’t allow me to)


#4

Hello @frasej

We would like to look into this further, are you using STRIP on Windows or OS X where you see this behavior?


#5

Windows 7 Ultimate 64bit


#6

Hello @frasej

When you click the list of labels are they not sorted correctly, or is the selected item within the list not the first element? I am seeing the items sorting correctly based on the order specified within the custom label editor, however the selected item within the list is the Password field, which is not the first item within the list. I will look into this as it should be selecting the first item within the list.


#7

If I could send you a picture, you’d see. The items are not sorted, at all, when I try to add a field to a record. The only place I see them sorted is in the menu item “Customize Labels”.


#8

Hello @frasej

Can you confirm that within the File → Preferences window you have selected the sort by name instead of frequency as well?


#9

I’ve tried it both ways and it does sort differently, but I never, ever, ever get an alphabetical sort. Not even an uppercase vs lowercase sort.


#10

Hi @frasej

If you select sort by name and click Ok to close the Preferences window, then you open the custom label editor and click the name header column to perform the sorting based on your preferred order and close the window, do you still see random sorting if you then attempt to edit an entry and add a new field?


#11

That did it. Now it is in correct order. It was the clicking on the “Name” header in the “Customize Label” dialog box that did it. Thanks.


#12

Hi @frasej

Thanks for getting back to us, we are glad to hear it is working for you. We will consider making adjustments in the future to streamline this behavior.