SQL Chiper for Android ver.4.1.3 crashes on Android 5.1.1


Dear Team,

After updating SQL Chipper from 3.1.0 to 4.1.3 and releasing it to the market for 64 bit support, many Android 5.1.1 users have reported crashes.

As a result that we analyzed with Android 5.1.1,
It seems to be crashing with SQLiteDatabase.loadLibs.

W / linker: ourapp / lib / arm64 / libsqlcipher.so: unused DT entry: type 0x6ffffffe arg 0x7768
W / linker: ourapp / lib / arm64 / libsqlcipher.so: unused DT entry: type 0x6fffffff arg 0x3

As a trial, I incorporated an AAR using elf cleaner posted at the following URL, but it did not improve.

Finally, the problem was solved when a new application that incorporated SQL Chiper ver.4.0.1 was installed.
However, applications incorporating SQL Chipper ver.4.1.3 have already been released to the market and can not be easily downgraded.

Is there a problem with compatibility between SQL Chiper ver.4.1.3 and Android 5.1.1?
Please tell me the solution.


Hello @Shintaro,

We just restored a factory image of Android OS 5.1.1 onto a Nexus 9, then ran the SQLCipher for Android test suite using 4.1.3 and all tests pass. Out of curiosity, what device(s) are you seeing the error on? Are they the Oppo devices mentioned in the GitHub Issue you linked to?


Thank you for answer immediately!

We also restored ver.5.1.1 to Nexus 7 and confirmed its operation, but it worked without problems.

Apparently, it does not occur with all Android 5.1.1, but seems to be limited to some devices.

However, although the devices for which a crash was reported here are all models manufactured by a Japanese manufacturer, these are reports from multiple manufacturers, so it is unlikely to be a defect by the manufacturer.

The OPPO we referred to is the same error code, so I think it’s the same cause.

If possible, is it possible to check a little more on other Android 5.1.1 smartphones?

In addition, because SQL Chiper 4.0.1 works without any problems, is there no cause for the difference between 4.0.1 and 4.1.x?


Hi @Shintaro

Can you provide a list of devices models, with their Android OS version that have reported this issue? Also, are you a Commercial Edition license holder of SQLCipher for Android?


Hello Nick,

Thank you for your consideration.
Very sorry, we do not have Commercial Edition license.

A list of devices models is below.

  • KYOCERA DIGNO rafre Android 5.1.1
  • FUJITSU ARROWS M02 Android 5.1.1

The phenomenon appears to be limited to Android 5.1.1 and manufacturer models only.