Unable to remove older version of Codebook


#1

Hi there,

I’m unable to update to the newest version of Codebook. The installation proceeds just past selecting whether or not you want Dropbox, Google Drive, etc. support, and then the following window pops up.

CodebookSetup.msi is in the directory it’s pointed to, and I’ve also tried selecting the file, but I get the same error. I have also tried copying the file and changing the permissions to r/w/x for everyone, but that doesn’t help either. I’m currently running Codebook 3.0.7.0 w/ SQLCipher version 3.3.0 and support for all the cloud syncing options.

Any workarounds to fix this? Thanks!


#2

Hello @yorktronic

I’m sorry to hear about the issue with the installer. Would you try moving the installer to a different location, possibly your desktop to see if this behavior changes?


#3

I did that as well – I moved the installer to my home directory and pointed to it during the install to no effect. I also made sure the permissions were correct. I even added r/w/x for Everyone (this is on Windows 10). It still presents the same error.


#4

Hi @yorktronic

Would you try downloading a fresh copy of the latest Codebook for Windows installer to rule out some form of local file corruption? You can access the latest installer here:

https://getstrip.zetetic.net/downloads/codebook/windows/CodebookSetup.msi


#5

Unfortunately, still no success. Codebook won’t uninstall if I point it to that .msi when I’m trying to uninstall, and additionally running the installer has the same problem. I can’t uninstall Codebook and it’s driving me nuts.

I’ve removed all registry keys that reference Codebook, rebooted, and still it exhibits the same behavior. I’ve also tried third party tools like Absolute Uninstaller by Glary Utilities, which doesn’t see the program as installed, and IObit Uninstaller, which does see it installed but can’t uninstall it.

Trying to install Codebook to a new, different path does’t help either.


#6

Hello @yorktronic

I’m sorry to hear about the trouble this is causing. Microsoft has released a tool to help with installation/uninstall problems that is available here, it is compatible with Windows 10. Alternatively, we’ve heard of Revo Uninstaller working for other who have had uninstall issues, too. Would you mind trying those options and let us know your results? Thanks!