Can't build SQLCipher on Windows10

I am trying to install SQLCipher on Windows10 for weeks now, but I always get the same error after I run the ./configure (with various arguments) and the make clean:

*** Warning: linker path does not have real file for library -lz.
*** I have the capability to make that library automatically link in when
*** you link to this library. But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libz and none of the candidates passed a file format test
*** using a file magic. Last file checked: C:/Qt/Tools/mingw730_32/i686-w64-mingw32/lib/libz.a
*** The inter-library dependencies that have been dropped here will be
*** automatically added whenever a program is linked with this library
*** or is declared to -dlopen it.

*** Since this library must not contain undefined symbols,
*** because either the platform does not support them or
*** it was explicitly requested with -no-undefined,
*** libtool will only create a static version of it.
libtool: link: ar cru .libs/libsqlcipher.a sqlite3.o
libtool: link: ranlib .libs/libsqlcipher.a
libtool: link: ( cd “.libs” && rm -f “” && ln -s “…/” “” )
shell.c sqlite3.c
-lz -rpath “/usr/local/lib”
shell.c:2717:1: error: operator ‘||’ has no right operand
pCur->nLvl = nNew;
make: *** [sqlcipher.exe] Error 1

This is my openssl version

OpenSSL> version -a
OpenSSL 1.0.2r 26 Feb 2019
built on: reproducible build, date unspecified
options: bn(64,32) rc4(8x,mmx) des(idx,cisc,2,long) idea(int) blowfish(idx)
OPENSSLDIR: “/usr/local/ssl”

I could not find anything that solves the “error: operator ‘||’ has no right operand”.

Thanks for your help.