IntelliJ Android compile error with v3.3.1-2


#1

Hi guys,

I’m developing an app with SQLCipher, first I (accidently) used v2.2.whatever and everything worked fine. But I was missing some important features, so I updated to v3.3.1-2. Now I’m getting this error:

Error:Gradle: Execution failed for task ':app:dexDebug'. com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process 'command 'C:\Program Files\Java\jdk1.8.0_60\bin\java.exe'' finished with non-zero exit value 2

I googled this error and the internet said to add multiDexEnabled true, I did this and I get this error:

Error:Gradle: Execution failed for task ':app:packageAllDebugClassesForMultiDex'. java.util.zip.ZipException: duplicate entry: net/sqlcipher/IContentObserver$Stub$Proxy.class

I’m trying to solve this issue for more than a week and didn’t find any solution and this is annoying like hell.

Thanks for your help!

Cheers


#2

Did you remove everything from your v2.2 integration? This would include all relevant SQLCipher JARs, plus the native libraries.


#3

Yes I did. I removed everything and added the new .jar and .sos. I also created a new empty project and added SQLCipher and there it worked totally fine…

EDIT:
Okay I got it working by simply repulling the project and rebuilding. Everything is fine now. Seemed like IntelliJ or gradle cached some files quite strange.
(But after all: shame on me by not getting this idea some days earlier)


#4

Well, your new empty project test suggests that there’s still v2.2 stuff lingering around your original project, or possibly two copies of the new stuff. BTW, unless you’re still using Eclipse+ADT, you really should be using the AAR, rather than the old-style manual installation.