Terminating app due to uncaught exception

I use this library to encrypt CoreData, GitHub - project-imas/encrypted-core-data: v2.0 - iOS Core Data encrypted SQLite store using SQLCipher, this library the old versione has problem with Migration data but now I updated with new version.But the issue is when I run the app it gives the error:

>  Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'This NSPersistentStoreCoordinator has no persistent stores (unknown).

It cannot perform a save operation

the error link to SQLCipher but I can’t understand exactly the issue.

Hello @Steven.H.A, I’m sorry to hear about the trouble you’re having, though this probably isn’t something we can easily help with because it doesn’t seem to have anything to do with SQLCipher core. Have you tried opening an Issue on that github project? The developers of that wrapper might be better suited to assist.

Hi @sjlombardo Thank you for response, yes I have opened issue but seems the project haven’t been updating since 1 year. I found the similar issue in stackoverflow that some developers has the same issue with the same project, the main problem is, it looks like SQLCipher gives error for that incorrect password.
Just a question, since we have been using this library, I have seen that you provide your own library that compatible with iOS the commercial one, so is that easy to change this library with your library, in the way that our clients not lose their data during updating?

Hi @Steven.H.A , yes, it seems as if that library is no longer being actively maintained. I too have see errors related to incorrect encryption keys, however they throw a much different exception. How are you determining that NSInternalInconsistencyException is being caused by SQLCipher?

Hi @sjlombardo, it was my mistake the problem not cause from sqlcipher, it was the library it self.
Can I ask if Sqlcipher SDK for iOS, I mean the commercial one has all documentation and API to encrypt CoreData.

Hi @Steven.H.A - that’s great to hear, I’m glad it was unrelated to SQLCipher. To answer your question, no, the Commercial Edition libraries to not provide a CoreData API. The library you are already using is the only CoreData library I’m aware of, and as you have noted, it’s largely unmaintained and unsupported.