Codebook for macOS 3.1.2 Released


#1

We have a minor update out today for the macOS version of Codebook that makes the following changes:

  • Corrects issue of duplicates in plain text exporter output
  • Updates certificate public key pinning for the anonymous statistics service
  • Fixes non-toggling edit button when editing notes

Codebook’s anonymous statistics feature is always disabled by default and doesn’t ever “phone home” unless you turn it on. It gives us information on how Codebook is being used so we can make it better, we hope you will consider enabling it!

Download: Mac App Store

If your purchased Codebook (or STRIP) in the Mac App Store:

  • Visit this link on your Mac
  • Click the “View in the Mac App Store” button
  • It will launch the App Store app and display the Codebook page
  • Click the Install or Update button below the Codebook icon
  • When installation completes click the Open button, or launch Codebook from Applications or Spotlight

Download: Direct from Zetetic

If you purchased Codebook directly from Zetetic (outside the Mac App Store):

  • Download the update
  • If Codebook is still running, quit the app
  • Unzip the file, drag Codebook to your Mac’s Applications folder
  • If prompted whether to replace the existing version, choose Replace
  • Launch Codebook from Applications or Spotlight

Support

If you are having trouble updating or have any questions please get in touch with us at support@zetetic.net.


#2

Hi - noticed something odd in 3.1.2.

  1. bring up secret agent and it gives the “codebook is locked” message
  2. start typing my master pass in secret agent but change my mind and decide to log in directly to codebook, leaving a couple characters of my password typed into the SA login form
  3. switch to codebook proper, and unlock with master password
  4. switch to website I’m logging into, and bring up secret agent again via the short code, but, it still says codebook is locked

Besides this anomaly, is there a reason unlocking from within SA does not unlock codebook proper fully?


#3

Hi @rickcogley

Thanks for this report and outlining the steps. I was able to reproduce the strange behavior. Specifically as you mentioned typing an incorrect passphrase in the Secret Agent Login view (and leaving it there), then entering the correct password into Codebook proper. I believe we’ve got a resolution for that issue.

I think this behavior could use to be adjusted as you mentioned. We’ll work on a fix for keeping the two in sync – I believe the main spot it needs adjusting is when you unlock SA, Codebook proper should unlock.

The other two behaviors should already be in sync:

  • Unlock Codebook proper → SA unlocks
  • Lock Codebook proper → SA Locks

Would you be willing to try out a beta when we’ve got one ready to confirm the new behavior is correct?

Cheers,
Micah


#4

That’s great and sure, I’ll test it.
Kind regards
Rick


#5

@rickcogley

Just uploaded the beta (3.1.4 build 407) to https://www.zetetic.net/downloads/codebook/osx/Codebook-direct.zip

Here’s a brief description of the adjustments made:

  • Fixes improper behavior when partially entering your password into Secret Agent login prompt
  • Unlocks Codebook when logging into Secret Agent
  • Secret Agent edit entry button now opens the main Codebook window if it isn’t already open

I know the last beta there was an issue with the code signing when you downloaded it, so you could run this command once you unzip the beta version to verify the code signing is all in order before moving it to the applications folder:

spctl --assess --verbose=4 --type execute ~/Downloads/Codebook.app

It should report “Accepted”

Thanks again for taking the time, and let me know what you think.

Cheers,
Micah


#6

Hi @mmoore - ok, I downloaded, unzipped, then tested:

~/Downloads ❯❯❯ spctl --assess --verbose=4 --type execute Codebook.app
Codebook.app: accepted
source=Developer ID

So, no problem w/ the integrity of the download.

But then I drag-drop the .app to /Applications and, same problem: I get "%@ can't be found".

I’ll try to clean it up. I’m using Path Finder, a Finder replacement. I wonder if it’s messing up the over-write operation, when I drag the .app into /Applications. Hmm…


#7

Ok, I fully deleted the app and tried the beta again. I get this error when starting:


#8

Ok, tried again and it turns out that Path Finder is causing some trouble when copying. When I copy with regular Finder, it works.

But, it does not work, because I cannot get the sync set up. I selected to restore my data, and then it tried to force me to log into Google Drive when I was just trying to use the wifi sync.

I cancelled out of Google Drive, and now the app is stuck, somehow. I restart, and it reverts back to the initial state of showing the “what’s new” popup and telling me about Secret Agent. This is the same no matter how many times I restart and try again.


#9

Ok, somehow I got it working, but, sync is still oddly broken.

  1. used app cleaner to delete completely
  2. downloaded beta
  3. unzipped and used finder to copy to /Applications
  4. entered master, and selected wifi for restore
  5. it ignores and uses Google Drive - this time I did not cancel and just entered my G pass. Syncs.
  6. Selected user scripts after clicking use SA in popup
  7. went to Prefs to set SA shortcode and notice SA is not enabled. Re-enable, re-select user scripts etc.
  8. Set sync up but, Sync button is greyed out and I cannot select

#10

An observation,

The new feature of “unlock SA, and Codebook proper unlocks” works, I’m pleased to say.

However, Codebook does not honor the lock settings in Preferences. I have it set long, but it locks in minutes.


#11

Another observation -

Now when I restart Codebook, it “forgets” my settings. It’s stuck in the initial popup mode with the list of versions, and the prompt to enable SA.

… actually, it’s even happening every time I lock and unlock.


#12

@rickcogley what version of Path Finder is on your system? It was updated recently to support macOS Sierra’s file system and again to fix bugs with drag and drop that I believe to have been related. Sandboxed apps are quarantined until run and there’s some special stuff the system does to maintain that while you move a binary around in Finder.

Right now I think permissions for Codebook’s defaults database (and perhaps other items in the container) are inconsistent with what they should be, perhaps due to a damaged binary or some other issue.

First, let’s try and see if a container repair helps with the persistence of your preference changes:

  1. Quit Codebook if running
  2. Open Terminal and paste the command:

asctl container repair /Applications/Codebook.app

Then try launching Codebook again, make some adjustments to Preferences and see if they are maintained.

If that doesn’t do it, I’d say we should back up your data file (default.strip), remove the container directory, have the app re-create it, and then move your data file back into place, but hopefully we can avoid that.


#13

@wgray, I’m afraid it did not work. The repair appears to have given a positive result though.

~ ❯❯❯ asctl container repair /Applications/Codebook.app                       ⏎
Beginning repair of: /Users/rcogley/Library/Containers/net.zetetic.Strip.mac
   Rebuilding container...
   Migrating application content into container...
   Saving updated container information...
   Rebuilding sandbox profile...
   Repair completed.

#14

@wgray As for Path Finder, I did not use it for this particular install, but rather used regular generic Finder. I am using the latest PF though, v 7.4.1 (1704).

Should I remove /Users/rcogley/Library/Containers/net.zetetic.Strip.mac, is what you mean?


#15

I did this, from another forum post:

  • Quit STRIP if running
  • Switch to Finder, select Go -> Go To Folder (or shift+command+G) and paste:
    ~/Library/Containers/net.zetetic.Strip.mac/Data/Library/Application Support/
  • Drag the Strip folder somewhere convenient outside the container (e.g. Desktop)
  • Go back to ~/Library/Containers
  • Delete the folder net.zetetic.Strip.mac
  • Double-click on STRIP in Applications to launch
  • Set a dummy password (or your own), and go to STRIP menu -> Preferences

Last I restored from Google Drive, and the entries come back as expected, but, still the same problem of Codebook “forgetting” its settings.


#16

@wgray, what can I do about this, can I manually set permissions?
Regards,
Rick


#17

I just don’t get what is going on. I decided to try a complete restore.

  • I cannot sync so I backed up manually, both the latest backup file and the default.db.
  • I used appcleaner to delete all traces.
  • Installed non-beta, stable 3.1.3 to /Applications using Finder (not Path Finder)
  • Entered initial same master password and confirmed nothing is in the db.
  • Shutdown Codebook and copied default.db into place using Finder (~//Library/Containers/net.zetetic.Strip.mac/Data/Library/Application%20Support/Strip/)
  • Started Codebook, unlocked and confirmed data (has latest)

I cannot sync or set up sync. How odd, because I could do so before in 3.1.3. Does the beta install some sync-related binary that does not show up when I delete Codebook.app via AppCleaner?


#18

Ok, I noticed that there is no “repair permissions” in macOS Sierra, so I went ahead and did my usual cache cleanup via Cocktail. After that and a restart, voilà, it works again. This is using the stable 3.1.3.

FYI


#19

Hi Rick,

Sorry we didn’t get back to you the last couple of days. That’s very weird that a cache cleanup fixed the issue, what caches are being cleared?


#20

hi @wgray - happy thanksgiving.

It’s a lot of stuff it does. Best thing is to install Cocktail and check what the “pilot” section does. This is just a way to automate the clearing / cleanup. I uncheck cookies and web search history and saved application states, but let it clear everything else.

FYI,
Rick