Secret agent window stops appearing after a while

I have an issue where the secret agent window initially works, but eventually stops responding to the hot key. When this happens I can open the application window from the dock, and close it immediately, at which point I can launch secret agent again.

I haven’t figured out how to reproduce this reliably. It doesn’t seem related to the screen saver (which would automatically lock Codebook), and it doesn’t seem related to other applications running.

Codebook 4.5.7 on macOS Monterey 12.6

Hi @gonewest818

Thank you for using Codebook and reaching out, although I’m sorry to hear about the trouble. We recently identified an issue which was causing Secret Agent to fail to work on certain M1 machines which aren’t running Rosetta.

Would you try out the beta and let us know if the behavior is any different for you? If you’re using the direct version of Codebook for macOS, you can get the beta by going to Codebook menu > Preferences > Updates tab, change the release channel to Beta and click “Check For Updates”.

If you’re using the Mac App Store version of Codebook, you can switch over to the direct version to temporarily test the beta using these steps:

  1. Go to this link: Download Codebook for macOS - Zetetic and choose “I already have a license”, then download the Codebook disk image.
  2. Delete Codebook (Mac App Store) from your Applications folder.
  3. Run the Disk Image to install the direct version of Codebook for macOS.
  4. Launch Codebook for macOS and follow the steps above to download the beta.

After downloading/installing the beta, open Codebook again and uncheck/recheck the Secret Agent preferences in Codebook menu > Preferences > General tab.

Let me know if the beta helps at all. Thanks!

1 Like

Oh, but I have an Intel mac, not an M1?


Thanks for the reply with the additional information. Because you’re not running an M1 Mac, the issue explained in my previous post is most likely unrelated.

Are you using a custom hotkey for Secret Agent or the default one?

Hi Micah, I just use the default hotkey to call up Secret Agent.

(and it’s happening right now, I can’t get the secret agent window to appear)

Could you try running this command in Terminal (launched via Spotlight search or via Application > Utilities > Terminal):

launchctl list | grep -i strip

It should report something like this as one of the line items:

537	0	net.zetetic.STRIPHelperAgent
  • Does that show up (with a different first number)?
  • Is the middle number something other than 0 (for example 78)?

Here’s what I get:

2251	0	net.zetetic.STRIPHelperAgent

Thanks for sending that over. That looks correct to me – the Secret Agent helper application is running and doesn’t have a non-zero exit code (indicating it launched properly). That leads me to believe something may have gone awry with your System Privacy settings for Codebook (Accessibility & Automation).

Would you try this suggestion to see if un-checking and re-checking the Privacy settings here help: Troubleshooting Codebook Secret Agent

If you can’t uncheck and re-check the Privacy setting in Accessibility after hitting the unlock button and authenticating in the lower left hand corner, would you try removing Codebook from the Accessibility privacy setting by selecting Codebook from the list, clicking the - button, then clicking the + button and selecting Codebook in the Application directory to re-add it.

Let me know the results.

Those accessibility and automation preferences were already enabled, so I unchecked and checked them back on again. No change. But did I need to logout or restart after changing those prefs?

Yes, please quit Codebook and restart it if you didn’t, it wouldn’t hurt to restart your machine as well just in case. Also try unchecking and re-checking the Secret Agent Preference in Codebook menu > Preferences > General tab.

If that doesn’t work, would you please check if you have multiple Codebook installations present on your machine. You can use this command in terminal to determine it:

find / -name Codebook*.app 2>/dev/null

It should only return two locations:


Ok, then this will be my last update for a while. When I open the Codebook app (even if I don’t authenticate) it seems to “reset” things so the Secret Agent hot key does start working again. I’ll have to wait some unknown amount of time before it might happen again.

Here are the 2 app bundles, as you expect:

$ find / -name "Codebook*.app" 2>/dev/null

Actually, I restarted the machine and almost immediately the problem reproduced.

  • Is there a specific application which has focus when you’re attempting to call Secret Agent (i.e. Safari)?
  • If you bring up TextEdit and attempt to call Secret Agent and insert, does the same thing happen?

It’s typically a browser, but doesn’t matter I which application has focus. It can even be the Finder, ie no application at all.

Thanks very much for the reply and sorry I haven’t been able to get the bottom of the issue with you yet. We’re upgrading some additional machines to macOS Monterrey 12.6 to see if we can reproduce the issue on any of them.

In more recent versions of macOS we have identified that there is a conflict (with a global hotkey) with the default hotkey used for Secret Agent, it hasn’t been causing issues during any of our testing, but I wonder if things may have changed in macOS Monterrey 12.6.

To test this, would you mind temporarily switching your Secret Agent hotkey to something else (i.e. CMD + SHIFT + ;) to see if the behavior is any different using that?

If the behavior is the same, you can switch the hotkey back to the default, but you won’t be able to do it in the Codebook interface (because of the global hotkey conflict I mentioned above). Here are the steps to switch it back:

  1. Quit and close Codebook if it’s open.
  2. Open terminal and run this command: defaults delete net.zetetic.Strip.mac ZSSecretAgentHotKeyPreferenceKey
  3. Open Codebook and the hotkey should be switched back to the default now.

Thank you for your patience as we help troubleshoot this.

Sure. I’ve switched the hot key, and will report back what happens.

Note, on my system I see in System Preferences > Keyboard > Shortcuts > Accessibility > Zoom, there is a shortcut “Turn image smoothing on or off” with the key binding that conflicts with Secret Agent. In my case those Zoom accessibility keys are not enabled (the checkbox for that part of the list is unchecked).


Just wanted to follow up with some additional findings on our end. We were able to reproduce the issue you are describing after updating a couple more machines to Monterrey 12.6. It seems to occur after the computer sleeps and then unlocks opens again. Does that line up with when you’re seeing it as well?

During the tests we’ve done, it seems like either of these allow it to work again (until the next sleep occurs):

  1. Unchecking and re-checking the Secret Agent Preference in Codebook menu > Preferences > General tab.
  2. Unchecking and re-checking the Accessibility & Automation Privacy Settings for Codebook in Apple menu > System Preferences > Security & Privacy > Privacy tab.

We’re investigating what could be occurring here to see if we can fix it on the Codebook side or if this is a macOS bug which needs to be reported to Apple. I’ll post with an update as soon as we have any additional findings. Thanks!

@mmoore Just wanted to drop a quick thank you for this feed! I was about to start crying that my Secret Agent wouldn’t work even after completing all the steps in Troubleshooting Codebook Secret Agent article.

And then I found this feed :heart: (Yes, I have a new M1 Mac. And yes, the beta update to 4.5.8 fixed the issue).

Maybe just a quick note for the future support - I still had to complete the “terminal restart of a STRIPHelperAgent”, because it was in 78.

Quick note 2 - maybe you could mention the beta update in a “Troubleshooting Codebook Secret Agent”. It would’ve saved me some time of googling.

1 Like


Sorry to hear you ran into the issue. Glad to hear you found this post and the beta resolved the issue for you.

Quick note 2 - maybe you could mention the beta update in a “Troubleshooting Codebook Secret Agent”. It would’ve saved me some time of googling.

I just updated this post to include a note about the known issue on certain M1’s with instructions on how to download the beta to the top of that post. Thanks for the suggestion.

Maybe just a quick note for the future support - I still had to complete the “terminal restart of a STRIPHelperAgent”, because it was in 78.

Will add this to the beta post/release post so folks know. Unchecking and re-checking the Secret Agent Preferences would probably be easiest.


We believe we’ve identified the issue. We’re doing some further internal testing now to confirm. I’ll post back up here when the next beta version is available with the fix so that you can confirm it resolves the issue on your end as well. Thanks!

1 Like