Secret Agent on MacOS Majove not working


#1

Just upgraded to MacOS 10.14 Majove and SecretAgent stopped working.
Codebook preferences show it is turned off and when I try to turn it on it directs me to choose the scripts folder,
But that folder can not be selected.
See screenshot where the “Choose User scripts folder” is not active.
Thanks


#2

Hello @jcschell

Would you confirm whether you have added Codebook to the Accessibility section within System Preferences → Security & Privacy → Privacy → Accessibility?


#3

It wasn’t so I added it.
Still no luck.
I completely uninstalled and reinstalled Codebook
Still not able to set up secretAgent
See images.


#4

Hello @jcschell

Are you using a beta release of Codebook for macOS by chance? What version do you have installed?


#5

V3.6.6 via the Apple Store

48%20PM


#6

Hello @jcschell

Is there any chance you have more than one copy of Codebook for macOS on your machine (i.e., in two different folders)? Just to confirm how many you have, would you launch the Terminal application (located within the Utilities folder within Applications) and execute the following command:

find / -name Codebook*.app 2> /dev/null

#7

I guess this means that only 1 exists.


#8

Oops, here is the completed run


#9

Does this help?


#10

Hello @jcschell

To rule out a local corruption of the installation, would you mind deleting the application located within your /Applications folder, then reinstalling directly from the macOS App Store? Your data will remain safe as it is stored in a separate location from the application. Thanks!


#11

I tried that before I started the thread.


#12

Hello @jcschell

Would you be interested in try a beta build of Codebook for macOS to see if that resolves the issue?


#13

Yes I’d be happy to.


#14

Hello @jcschell

We have just added you to the Codebook Beta group on discuss, you should now see a link in the navigation. We have posted new beta builds available there. Would you try the latest beta when you get the chance and keep us posted? Thanks!


#15

short answer: same behavior. I posted the details at:
https://discuss.zetetic.net/t/codebook-for-macos-beta-3-7-0-desert-fox-new-installer/2983


#16

For anyone else experiencing the same issue, here’s a further explanation/workaround:

An application called ViewIt was associating anything with a .mac extension with itself (causing it to no longer be a “folder” type). So when you attempt to select it when enabling Secret Agent, it doesn’t allow you to (because the open prompt for Secret Agent only allows folder selection).

Unfortunately, there’s not really a built in/easy way of un-associating the .mac extension with the ViewIt application.

Previously I believe you could use a third party app like RCDefaultApp (http://www.rubicode.com/Software/RCDefaultApp/) to “un-associate” the .mac extension, but it hasn’t been updated in a long time and doesn’t work on Mojave (at least from my testing).

This workaround should allow you to select/enable Secret Agent and then bring the ViewIt app back into place:

  1. Open Finder > Applications, move the ViewIt app to the trash (but don’t empty the trash).
  2. Open and Unlock Codebook. Preferences > Enable Secret Agent and attempting to select the net.zetetic.Strip.mac folder (I was able to select it on my end as long as the ViewIt app was currently in the trash).
  3. Confirm that Secret Agent is working properly again.
  4. Go to the trash select ViewIt > Right (ctrl) Click > Put Back
  5. Attempt to call Secret Agent again to ensure it’s still working properly.

It seems that associating .mac extension with the ViewIt app tend to negatively affect other applications (other than Codebook) as it’s relatively standard to name your containers with a .mac extension. Hopefully the ViewIt application developers will rectify this in the future, but until that point our recommendation is to either use the workaround posted above, or uninstall ViewIt.


#17

I found a great replacement viewer for ViewIt.
ApolloOne
It is fast, does everything ViewIt did and then some.
No compromise here.