Codebook Mac Issue - cannot use Secret Agent for Google Drive Desktop App


#1

hello - today I changed a lot of my critical passwords, and afterwards, had to login again to the Google Drive app that runs in OS X’s toolbar. When I tried using Secret Agent there, nothing would ever get pasted, no matter what I tried.

You might want to look into it. These are the steps I took -

  • authenticate newly with google in safari, use password and totp to get in
  • change password and confirm it
  • tell google to “change phones” for 2FA, which lets you reset
  • reset 2FA and confirm it’s working by logging out and back in

Then a few minutes later, Google Drive, running in the toolbar, prompted me for a password. I tried entering my credentials via SA, but nothing works and I cannot do the normal enter-to-paste operation. When I do, simply nothing is returned.

But copying the password from the Codebook password field manually works fine. So it’s not like the password is incorrect.

(in other apps, SA is working fine, so this appears to be localized)


#2

Another one that does not work is standard Dropbox web login, via Safari Version 9.0.3 (11601.4.4) on latest OS X El Capitan. When I copy the password out of Codebook and paste it, it’s fine. When I try using Secret Agent to insert it, it never works.


#3

Hi @rickcogley

I was able to reproduce the inability to use Secret Agent with the Google Drive App. We think that it may somehow be blocking the input from Secret Agent and we’ll look into it. I wasn’t able to reproduce the inability to use Secret Agent with Dropbox [I’m using El Capitan 10.11.3 and Safari 9.0.3 (11601.4.4)]. I know that we’re using the same version of Safari, is that also true for El Capitan? Just to verify, are you signing in through https://www.dropbox.com?


#4

Hi @mmoore. I’m using OS X 10.11.3. Yes that’s the URL. I’ll try again after a restart.


#5

Ok, sorry, Dropbox web works fine after a restart. Sorry for the false alarm.


#6

Ok @mmoore, here’s another one I found. The sync settings for Chrome browser. When you try to use SA to enter your credentials for those, it just does not want to work.

Chrome Version 48.0.2564.109 (64-bit)
OS X 10.11.3


#7

Hi @rickcogley

I was unable to reproduce the inability to use SA for setting and entering a passphrase in Chrome Browser sync settings on both my Mac (using the same OS X/Chrome version you are) or on my Windows 8.1 VM. Here’s a screenshot of the Advanced Sync Settings I was testing it on:

This was accessed through Google Chrome -> Settings -> Advanced Sync Settings
Could you let us know if this is the same place you’re having issues entering credentials from SA?


#8

hi @mmoore in this case, I have been using my google account credentials. After some time passes, a message appear saying something to the effect of “reconnect to refresh your credentials”, and the problem occurred when I do that.

I need to look into the difference between doing it that way, or using the “own sync passphrase” method as you highlight above.


#9

Ok, reading a bit, one thing is apparent: signing into chrome w/ the google account also signs you into gmail and youtube etc. Where I saw the alert that I needed to sign in, was actually not in settings, but rather coming from the upper right icon where my name shows. Now it’s logged in and looks normal, but there was some indicator on it when I did the operation to sign in, and found out that the dialog and secret agent did not get along so well.

This is what I mean:


#10

Ok, tried an experiment and disconnected my account from google. When you do that, it closes everything and deletes everything. Then, although you can select to log in from the upper right, a standard login web page for google appears. This is different from that state I am trying to describe, where the browser recommends “refreshing” credentials, because that was a modal popup, and nothing got disconnected or deleted when I re-logged in.

Doing it from zero works fine.


#11

Ok, this describes the situation (google credentials were “expired”)-
https://productforums.google.com/forum/#!topic/chrome/hSwQaalZE1A


#12

Hi @rickcogley

From the screenshots provided in the Google forums link it appears the login window will minimize when it loses focus. So as soon as you bring up Secret Agent (and that gets focus) the login window will go away. Is this the behavior you’re describing?

That’s the behavior I saw when I tried to reproduce the issue by logging into Google Chrome, changing my password, then trying to use SA to enter credentials for re-authenticating. Unfortunately you can’t use SA to login to windows that minimize or close when losing focus.


#13

Yes, it kept disappearing. Noted that it just does not work in that case. Copy-paste is fine as it really does not happen that often.

Thanks for looking into this!