Secret Agent doesn't drop in password


#1

Repro:

  • 1 year old macbook pro retina 15", OS X 10.9.4
  • upgraded to strip 2.4.0 today
  • trying to paste password into paypal.com and clippercard.com in Chrome 36.0.1985.143
  • Secret Agent modal comes up with hotkey and I’m able to find relevant site entry and select password field. However when I hit return, the modal disappears without depositing a password into Chrome.

#2

Hi @loganh

Thanks so much for using STRIP and sorry to hear about the trouble. It sounds like perhaps the setting didn’t take, could you have a look for us?

  • Fire up STRIP, sign in, have a look at Preferences—is the Secret Agent option still enabled?
  • Switch to Finder
  • Select the Go menu item, then Go To Folder
  • In the textfield that appears, paste this path (all one line):
    ~/Library/Containers/net.zetetic.Strip.mac/Data/Library/Application Scripts/net.zetetic.Strip.mac
  • Does that folder come up for you in Finder? If so, is it empty?

#3

This worked for me: I had never enabled “Enable Secret Agent while STRIP is not running” because I wanted the Secret Agent to require the password, too. Inserting anything into the currently active text field of the browser would not work. Inspired by @wgray’s points, I enabled the option, and let STRIP install it’s script. With the option checked, all of a sudden the insertion worked. And guess what, after I turned the option off again to force Secret Agent to ask for the password when STRIP is locked – the insertion still worked.

To me it hence seems that the script is always required, not only for Secret Agent to bypass the lock state. So the STRIP devs might choose to revisit their install process once more? Oh, and once you’re there: to me there is no point in asking the user for the script directory. 99.999% of the users won’t know what you’re asking for. So why bother asking, and not just use the default? Just my 2 cents anyway.


#4

Thanks for the reply. The secret agent option was NOT enabled - I incorrectly assumed that checking that meant by-passing the password, and in any case I always have STRIP running in the background. Since enabling that option in the initial setup flow seems to be required, I would make it a default instead of a user choice in the install flow.

Checking the option and setting the path to the script solved the issue.

Thanks.