Cant get secret agent to work


#1

I go to preferences and:

Select the Enable Secret Agent with keyboard command.
I select the folder ~Library/Application Scripts

When I try the shortcut, nothing happens.
I close Strip and open it up again. The Secret Agent checkbox is unselected.

I tried rebooting the computer. No change.

What am I doing wrong?


#2

Hi @maish, sorry to hear about the trouble! Let’s try the following:

  1. Quit STRIP for OS X if it is running
  2. Launch the Terminal app on your Mac
  3. Paste this command, all on one line:

defaults write net.zetetic.Strip.mac NSNavLastRootDirectory "~/Library/Application Scripts/net.zetetic.Strip.mac"

Now launch the app, sign in, uncheck the preference, wait a second (so the helper agent shuts down), then check it again. When the dialog opens to choose the scripts folder, don’t change the directory, just select the Choose button at the bottom of the dialog. It should now be set to the correct directory.

At that point close the Preferences window at test your key combination for Secret Agent. If it’s still not working, go back into Preferences and update the key combination preference to ensure the right keys.

Please let us know if that helps!


#3

Still not working. Some observations:

  • net.zetetic.Strip.mac is not a folder…it is a file with 0 bytes.
  • the default trigger keystrokes are command-shift-backspace right?

Also, after following your steps after I close and restart strip the checkbox is unchecked again.