Error building on NDK/Android Studio

#1

I’m trying to use sqlcipher in Android Studio in C. I’ve built the amalgamation file and moved it into
my native library. When I try to build, I run into this error:

This continues for several more lines down.
I’ve made sure to define SQLITE_HAS_CODEC before I include sqlite3.h.
I am currently using NDK r19c, but have also tried building with NDK r15c with no luck.

0 Likes

#2

Hi @khmermenten

We currently use Android NDK 15c to build SQLCipher for Android, and also do so on either macOS or Linux platforms, not Windows. Is there a reason you need to build from source on Windows?

0 Likes

#3

Thanks for responding. I was thinking that including the amalgamation file would be the easiest way to incorporate sqlcipher into my project. So, I built it on the windows linux subsystem (I only own a Windows machine), then moved it into my directory. I can now see how this would cause some issues, since it built for a different system. How would I build using NDK? I am currently using CMake for incorporating libraries.

0 Likes