Filter is not working please help


#1

As in the picture , it does not filter the data … what should i do pls help …

Thanks in advance …


#2

Hi @userboss

We don’t develop DB Browser for SQLite. Their webpage is located here: http://sqlitebrowser.org and the github project page is located here: https://github.com/sqlitebrowser/sqlitebrowser

That being said, I tested the filter on a couple of databases (both SQLCipher and SQLite) I have locally and it seemed to work fine for me. What is the type of your _id column?

If you execute a similar query directly through “Execute SQL” does it provide the correct results?

Perhaps @justinclift could provide some additional insight regarding this matter.

Cheers,
Micah


#3

Thanks @mmoore. :slight_smile:

@userboss Yeah, that is supposed to work… but it only seems to go ok if the column is defined as a number (eg INTEGER). I just tried it here with version DB Browser for SQLite v3.9.1, and that wasn’t working for text.

Is your _id column of type INTEGER?


#4

Hey guys thanks you very much for replying .
Actually for some weird reason it didn’t work when I first created the database but after reopening , filter worked completely fine with both “_id” and “oneto100” Columns.

Thanks.


#5

Cool, no worries at all. :slight_smile: