Can you run 2 Databases on 1 PC


#1

I use STRIP on my iphone and PC at home. I want my girlfriend to use STRIP on her iphone and on the same PC at home. Is there a way to run 2 databases from the 1 user account on the PC? We use the same login account.


#2

Hello @RBrink

Unfortunately at this time STRIP for Windows stores the database at a per user account level, so you would need to create another user account on the same machine in order to use STRIP with a separate database. The licensing of STRIP for Windows also allows you to install it on up to 5 PC’s using the same license, so that may be an option for you as well.


#3

I have STRIP installed on 1 PC and would like to install on two other machines (a new PC and laptop) in using the same license. I’ve read in your reply that I can add up to 5 PCs…where can I find the directions to do that? Thanks.


#4

Hello @gk_sync

I have just resent via a separate email your order fulfillment which will include your license key and a link to the latest installer. You can use the license key provided for your other machines.


#5

Many thanks, I will try to load it to the other machines and see how they work out.
Happy holidays😀

Georgia
Sent from my iPad


#6

Nick,

I have a couple of questions about importing a .csv file into a new windows
8.1 desktop install. Sorry, this is a bit longer that I thought it would be
:frowning:

I exported my STRIP .csv file from one desktop (Windows 7), to be installed
using a new license key provided by Zetetic on a new machine.

I installed the STRIP software app on the new desktop and tried to import
the .csv file into the newly installed version.
It didn’t appear to load. No errors, just kept ‘spinning and spinning’.

So I wonder if I can ask you folks the following questions, and whether
they could be causing the unexpected failure…
(by the way before I exported the file, I did an integrity check and there
were no errors)

  1. I have some FIELDS that contain no entry - would this cause a problem
    with the import? E.g. an account field type but no text entered for that
    field.

  2. I also have several things that have more than one set of fields (to
    keep similar info all in one record for ease in my use). For example, I
    have an entry that looks like the following

  • Category named Airlines (with the picture of the plane as the icon)
    • Entry also named Airlines
      • It contains blocks of fields for different the airlines (USAir,
        Southwest, United…etc)
      • I added a separate block of field types for for each airline (by
        selecting the + sign at bottom of screen) So each block has something
        like.:
        • account
        • username
        • password
        • email
        • notes
      • The Airlines entry as a result has 3 or 4 separate password,
        note, usernames, etc. entries. I end up with something like this

Category=Airlines

Entry = Airlines

Multiple fields =

  • account USAIR
    - userid xxxxxxx
    - password xyz
    - email example@somewhere.com
    - note blah, blah, blah = this or that; some other
    info

          - account    Southwest
          - userid       xxxxxxx
          - password  xyz
          - note         blah, blah, blah = this or that; some other
          info
    
          - account    United
          - userid       xxxxxxx
          - password  xyz
          - note         blah, blah, blah = this or that; some other
          info
          ...etc
    

Would this type of record cause the .csv import to fail?

3.  Another separate issue:  I 'cut&pasted' a bunch of older info from

a word file about passwords, accts, email,
etc into one field, so there is this long block of random info.
Looks like this

                      CATEGORY= Miscellaneous

ENTRY = personal info dump

NOTE = big ole blob of multiple pieces of information, containing

text entries, email addresses, passwords, serial numbers, some other random
bits/bytes of info. Has multiple paragraphs of info (e.g., carriage
returns embedded in the text)

Also contains things like special characters,e.g.
= ,; ( ) $ . to % & * / [ ] @ | ? ~

includes other bits and pieces of text or numbers (like serial

numbers, MAC addresses, purchase dates, cost, etc.)

Info may also be pasted in as

passwd=xzyabc; username=Somename; date=01/01/2001

Would these types of things all embedded in one note FIELD block cause the
import to fail?
Can I have an ENTRY that has no FIELDS? As a placeholder for something I
want to add but haven’t gotten around to yet.

Again, would having any type of carriage returns or tabs within fields
cause problems when I try to import the file

  • I have lots of things in notes with added carriage returns, like the
    above example, as well as tabbed spacing for visual readability
  • I may even have an “Alt-Carriage return” in one or two places (e.g.,
    copied from another file and pasted into the field in STRIP)
4.  Is there a max size to any given field, and is there any 'expected'

format for a given FIELD (e.g., "email"
entry expects to see name@somewhere.ext in that block)?

Lastly:

In my older exported .csv file, the content starts with the first title row
beginning with Category|Entry…
When I read through the directions to import .csv file, it mentions I must
have the titles at the top of the file in the first row, but it lists Entry
then Category …would this cause the import to fail (Category vs Entry as
the first item in the row)?

Do I need to fix that before I import, e.g., export .csv and get into
Excel, switch the columns then save as a new .csv file to import?

I did read in the notes also that if you added multiple emails to an EMAIL
FIELD, they would need to be separated by a pipe – so I guess that sorta
answers my question in number 4 above). But does that apply to multiple
emails in a different field (NOTE field for example), or multiple FIELDS
within a single entry (as in number 2 above).

Ultimately…

Before I undertake the task of editing all the entries in the existing
STRIP database, I thought I would run these questions by you guys and see
if they would indeed be causing the newly loaded version on the other
desktop to fail, and therefore I need to take such issues into
consideration as I update the records.

Roughly, with a newly installed STRIP, I would expect the .cvs import to
take a minute or two max for file of size ~30KB (is that a reasonable
assumption)? Since the initial import was spinning for about 5 minutes, I
figured it was stuck so just cancelled and ended the program.

That was more questions that I thought I had initially! And, I hope that
you can provide some clarification on the above questions and issues.

I actually love using STRIP for my passwords (and have on two iphones and a
desktop currently).
I hope I’ll be able to get the info transferred onto the new machines–but
if I have to go through an edit it’ll take a while, for sure.

Thanks in advance for any help or suggestions you can provide.

Georgia


#7

Hello @gk_sync

Thank you for your detailed inquiry regarding the import/export process within STRIP. Not to disregard your questions, but I think it may be easier to synchronize your entire database over to your new computer. Do you have any reservations doing that? The easiest way to do so would be to use either the Dropbox or Google Drive synchronization providers. We have put together some documentation on setting up the synchronization process here. Could you let us know if you think that approach might work, or if you have any further questions? Thanks!


#8

Hi, I tried the approach you suggested. The new desktop version of Strip
pulled in the data (using the WiFi sync) and all the icons defaulted to the
same shield symbol. I thought no worries, I can edit the entries and sync
from the new to the old desktop.

Unfortunately… I ran into the problem of double entries in my older
desktop system. I tried uninstalling Strip and doing a ‘fresh’ sync on the
old desktop --however it keeps going back to a google drive version that
has the multiple entries. Ugh. I also tried to remove the strip.db file
and re-sync, but it keeps retrieving the google drive copy with multiple
instances of entries.

Next I tried opening the strip app on the new desktop and now every entry
for my passwords and pin fields are entered as a series of dots (
…). What the heck happened??? Can this be fixed, or (gasp) have
I lost that info? It has also seemed to occurred on the old desktop too :frowning:
even after the complete reinstall

Help!


#9

Hello @gk_sync

Could you try this approach instead:

  1. From your old computer, login and select Overwrite Google Drive from the Sync menu
  2. From your new computer:
  3. Close STRIP for Windows if open
  4. Open the following folder from within Windows Explorer: %APPDATA%\Zetetic LLC\Strip
  5. Within that folder, delete the strip.db and settings.db files
  6. Launch STRIP for Windows
  7. Provide the same password used on your old computer with STRIP for Windows
  8. From the menu File → Preferences, select Google Drive as your synchronization provider
  9. Select Restore from Google Drive from the Sync menu

The above steps will replace the current data on Google Drive with what exists on your old computer, then pulling it down as a complete replica on your new computer. Could you try that and let us know if you are able to retrieve your data properly on your new machine? The masked characters on your passwords (and also your pin fields) is the default display mechanism to aid in security from passersby. Your data is still available, you can either copy the selected field, or right-click to display the field value itself. If you edit an entry you will also be able to see the raw value as well. You can manage which fields are masked from the customize labels menu option within the File menu.


#10

Nick,
Thanks for your follow up mail. In the end I was able to get the DB’s to
sync correctly, but it took multiple tries of installing/uninstalling the
application on my old desktop before I was successful. Because my old
desktop was already corrupted, I switched your suggestions around.

FYI, here’s what worked for me:

  • The DB on the new desktop was correct, so I used that as the basis to
    start.

  • I first saved this version to a .csv file, as well as selecting the
    ’backup database’ feature within Strip.

    • This DB is set to sync with Google Drive under preferences menu
      options.
    • I *completely *uninstalled the OLD desktop’s version of Strip, and
      any back-up .csv files I could find. (Trashed everything)
  • I also went to my Google drive and looked in the Zetetic folder and
    found a strip.db file

  • I removed that file.

  • By the way: I believe this was the beastie that kept giving me the
    duplicate entries and preventing a clean sync

  • Back On my OLD desktop. I

    • Re-installed Strip
    • Logged in and confirmed there were no records in the DB
    • Set the Sync to Google drive option in preferences
    • Selected Restore from Google drive from the Sync menu
  • OMG…eureka !!! It finally worked.

  • I now have an updated version on both old and new desktops.

  • I have also sync’d the DB correctly to my iphone and ipad.

(Oh and thanks for the tip about masking/unmasking the password and pin
fields–that was an easy fix [?] )

Again, thanks for all the helpful suggestions and guidance. I’m a happy
camper again.

Happy holidays!


#11

Hi @gk_sync

Thanks for getting back to us, we are glad to hear everything is working for you. Take care!