Codebook on HighSierra Issue


#1

Hi,

I have recently upgraded my Macbook Pro to High Sierra version 10.13.1.
Since the upgrade, I am unable to open my Codebook app.

Getting message:
“Codebook” is damaged and can’t be opened. Delete “Codebook” and download it again from the App Store.

I tried deleting and downloading again multiple times, but still not working for me.

Any idea what might be causing this?

Thanks,
Yuval


#2

Hi there @yuvdavid, sorry to hear it! This seems to happen from time to time with the Mac App Store. This might sound like it shouldn’t help, but could you try the following in this order if you haven’t yet:

  1. Delete Codebook
  2. Empty the Trash
  3. Reboot your Mac (this should reset all app store services)
  4. Launch the App Store app
  5. Install Codebook

If you continue to get the damaged message at that point, please launch the Console application from Spotlight, and search for messages containing either Codebook or net.zetetic.Strip.mac. There may be further hints in the system log as to what’s going on exactly.

Another thing we can check for diagnostics is the system security policy assessment of the app. To do this, launch the Terminal application and run the command:

spctl -a -v --type execute /Applications/Codebook.app