OS X 12.1 CodeBook won't open any more?

I tried to open Code Book today and I got the following error:

“Codebook.app” is damaged and can’t be opened. Delete “Codebook.app” and download it again
from the App Store.

I followed those instructions and I still get the same error?

I am running OS X 12.1 on an M1 MacBook.

It works fine on my other M1 MacBook but, that one is still running OS X 12.0.1 with CodeBook version 4.4.4?

Please Advise?

Don Myers

Hi @redrubicon07

Thank you very much for your support of Codebook and for reaching out, although I’m sorry to hear about the damaged message you’re receiving periodically.

This issue seems to sometimes occur with applications downloaded from the Mac App Store. Because it’s not specific to Codebook and rather related to an issue within the Mac App Store distribution, there isn’t anything within Codebook that we can specifically do to prevent/fix it. Here’s a reference to an OSX daily post about it: How to Fix App “is damaged and can’t be opened. You should move it to the Trash” Error on Mac and a few troubleshooting tips from our own discussion board: Mac App Store Download and Installation Issues

If none of those suggestions are helpful, we can get you moved over to the direct download version of Codebook which is distributed directly from us to avoid the issue with the Mac App Store. To do that, you can visit this page: Download Codebook for macOS - Zetetic and select “I already have a license”

Let me know the results. Thanks!

That is the strangest thing! For anyone else that might find this thread as per the first link:

  1. rebooted computer
  2. deleted the application
  3. re-download it from the app store
  4. open it!


Thank you for your help!


Excellent. Glad that did the trick and thanks for posting back what worked for you.

Please feel free to reach out again if you have any further questions, issues, or feedback.

Have a nice day!