App Crash on Mac - Will not launch


#1

Good morning,

I had Codebook installed on my 2014 MacBook Pro and it was working fine and syncing with my iPhone 6 without problems for about a week. This morning the app crashed on my Mac and simply refused to run. It shows that it is running in the taskbar, but there is no way to access it. I tried uninstalling it, rebooting and then reinstalling it to no avail. Nothing I do seems to help and the program simply will not run on my Mac now. Any suggestions?


#2

Hi @rickzski,

I’m really sorry to hear about the trouble. Can you tell us what version of OS X you are running? You can get this information by selecting the Apple menu on your Mac and choosing About This Mac.

Did you recently update OS X, or Codebook?

If the app is running and hung, you can forcibly terminate it:

  1. Select the Apple menu
  2. Click on Force Quit
  3. In the window that appears select Codebook and click on the Force Quit button

One more thing to take a look at is the Console:

  1. Using Spotlight (search icon in the menu bar) launch the Console app
  2. Click on Clear Display
  3. Launch Codebook
  4. Do messages related to the failure to launch appear in Console?

#3

Hi wgray,

I’m running OS X El Capitan. I did not recently update OS X or Codebook. I have forcibly terminated it to no avail. I also just tried your suggestion of clearing the display. It also didn’t work.

Any other suggestions? I’d love to wipe the program and all associated data off of my computer, and then reinstall the app and try it again. Would you happen to have instructions for doing this?


#4

We took care of this through our email support, but for anybody else following along who may be experiencing this issue, there is a work around:

  1. If Codebook is running and hung, go to the Apple menu and select Force Quit and Force Quit the app
  2. Launch the Terminal app
  3. Enter the command: defaults delete net.zetetic.Strip.mac

While this has the unfortunate side effect of resetting your Preferences in Codebook, it should get you back in action.

We have a fix coming for this issue in version 3.0.10 which we are testing now. Write us at support@zetetic.net if you’d like to join our beta testing list, we could always use more testers!