App Crash on Mac - Will not Force Quit or Launch


#1

Hello,

I am running the latest version of Codebook on a Mac with macOS High Sierra. This morning, Codebook would not quit. It also refuses to force quit. I tried the Terminal command: defaults delete net.zetetic.Strip.mac, but it also did not work. Now my Macbook Pro will not restart because Codebook is preventing it. What do I do??

Rick Z


#2

Hello @rickzski

Thank you for your support of Codebook, although I’m sorry to hear about the behavior you are experiencing. It is rather odd that Codebook would not even exit using the Force Quit Applications window. Are there any other applications with high utilization of either your CPU, or Memory within Activity Monitor? Have you experienced this behavior before? Since it sounds as if you may be familiar with the Terminal, you could launch a terminal prompt and execute the following commands which should kill the running Codebook instance on your machine.

ps -A | grep -i codebook | xargs kill -9 2> /dev/null

#3

Thanks. That didn’t work either, so I hard reset my laptop and that worked. I appreciate you getting back to me so quickly.

Rick Zurawski


#4

Hi @rickzski

Thanks for getting back to me. I left off the parsing of the pid. This should do it, should you need it again:

ps -A | grep -i codebook | awk '{print $1}' | xargs kill -9 2> /dev/null