FYI: I crashed v. 4.5.7 on a mac

I managed to freeze Codebook accidentally by editing the password field of an existing record, then entering a text string in the search field without closing the record I was entering. Codebook stopped responding, requiring a force quit.

The edit was not committed and no problems observed. The same search worked harmlessly as expected when I saved the edits to a record before searching.

I don’t remember this kind of thing happening with previous versions — FYI.

Codebook Version 4.5.7 (1025)
Mac App Store

macOS High Sierra v. 10.13.6
Mac mini (Mid 2011) 2.5GHz Core 95 / 16GB / AMD Radeon HD 6630M GPU 256MB

Hi @jtclayton

Thanks for using Codebook and posting to the discussion forum, although I’m sorry to hear about the trouble with the crash.

I have a few questions to get us started:

  1. Are you able to reproduce this issue every time you perform the steps outlined?
  2. Is there any crash report generated after Codebook stops responding?
  3. Could you open Console (accessed via Spotlight Search or Application > Utilities), select your device on the left hand side, start streaming, then filter on Codebook (in the search box in the upper right hand corner) then perform the steps to reproduce the issue. Would you send a copy of this console output to us at

We haven’t been able to reproduce it so far on Big Sur or Monterrey, but will test it on High Sierra and see if we can reproduce it there. Thanks!

Happily (sadly?) I can’t seem to replicate the crash here, either. I wasn’t too eager to break my password manager before, so till now I didn’t try.

Beforehand, I ran the integrity check (nothing found) and vacuumed the database (0% reduction).

Then I exported all the records as Codebook CSV and synced to an iPhone.

Then I tested with exactly same steps, or very nearly same, on a record picked haphazardly. Nothing bad.

So I went to the record I was in when I crashed before, and did the same sequence of steps.

When you start to key text into Codebook’s search field, the apps display spasmodically jumps to list the matching records as you go. This is where the app locked the other day — I never got to finish entering my searchword.

But today, no such problem. But we have Sun in Virgo and Moon in Scorpio today, which is important for database software?

I just sent the Console output as an email attachment, subject line " FYI: I crashed v. 4.5.7 on a mac " FWIW…


1 Like


Thanks very much for the reply and sending over the Console log. I wasn’t able to reproduce it on my High Sierra VM either.

We’ll continue to try to reproduce the issue on our end. I’ve sent over a couple of follow up questions via our email correspondence to assist us in trying to reproduce it.

But today, no such problem. But we have Sun in Virgo and Moon in Scorpio today, which is important for database software?


On Monterey, can’t upgrade to 4.5.8 and 4.5.7 is crashing (instant app quit when clicking sync button). Please advise how I can backgrade to a working version and/or if you’ll release a fix that keeps this working on Monterey (for now). Not ready to upgrade the MBPro just yet.

I also tried 4.5.7 on another MBPro running Catalina. Hitting the sync button starts a sync and gets to about 4% and just hangs. So there’s that.

Sorry to hear about the crash on your one machine and the sync stall on your other machine. Did you receive a crash report dialog at all when the crash occurred?

For the sync stalling, which sync method are you using?

If you don’t mind, would you write into us at with the contents of the crash report if available and we’ll be happy to help further. Thanks!