Delphi IDE malfunction when Strip is active (SOLVED)


#1

Hi there.
I have a problem using the Delphi XE2 IDE: when type a keyboard combination with the ALT key an undesired character appear in my text code, rather then doing the intended action.
For example if do [ALT] + [ArrowLeft] to go to the previous view a diamond (the cardgame suit) appear instead.
If STRIP is not loaded in memory this does not happen.
It never happened before the last release, so I easily guess that the issue is related to the secret agent feature.
What I know is that the Delphi IDE is based on a .NET framework that have something in common with Microsoft Visual Studio, a kind of IDE runtime that Microsoft provide.
So the two programs are clashing somewhere in keyboard management.
I’m using Windows 7 Professional with all the current service packs and patches applied.
Resolving the issue is obviously the best option.
As a work around the corner cases I would suggest an option to inhibit the keyboard activation of the secret agent, letting the user to call it through the system tray icon.

I must say that otherwise I’m really satisfied by Strip, both the Windows and iOS app.

Thank you,
Mirco

P.S. Just 3 minutes ago, while writing this topic, I called up Strip through the system tray and when suddenly back here I wasn’t able to type into anymore. I closed Strip and then typing was back to normal.
My browser is Opera 23, Chromium based


#2

Hello @mirmalag,

Could you try adjusting the key binding of secret agent, there is an editor available within the preferences window? This is currently mislabeled as Omni Window key binding within the window.


#3

I did, but it didn’t make a difference.
Also noticed in other programs that sometimes trying to type something the active window loses the focus.
This happens only when Strip is loaded.
I thought about any other software installed on my PC that could conflict with Strip but, can’t say any one to blame.

Mirco


#4

Some more to add.
After recall of the suggestion windows I double-click on the curved arrow beside a field to let the value go into something then, if the value contains the “@” character (as with an email address), that character is mistranslated:
the field contains name@domain.com and the page receive nameòdomain.com, with the accented “o”.

I also looked deeper into other possibly conflicting programs, trying to unload them selectively, but the problem remians.

What else could I investigate?

Thank you,
Mirco


#5

Hello @mirmalag,

We are preparing a fix to address the mistranslated characters along with adjustments to the key binding handling. Thank you for your feedback!


#6

…and thank you for your support!

Mirco


#7

It’s now solved in 2.4.10
Thank you!