Secret Agent not working using Original Surface Pro Keyboard and Windows 8.1


#1

I am unable to reliably get the Secret agent keys to bring up Strip. Rare occasions it will but I have been trying to get it to work for the last 20 minutes and no luck. Any help here?


#2

Hello @lwetzel

What version of STRIP are you using? In order to invoke secret agent, you must press the global hot key down simultaneously, are you doing that? Have you modified the global hot key binding within the preferences window?


#3

I had been trying with the default global hot keys. That was hit and miss. Mostly miss. I change to CTRL+ \ and that finally got to working . When I got your response I went back and changed it back to CTRL+ALT+ . That worked this time. I have noticed it seems to work if I jack with it enough. I think the two key combo is better because you’re more likely to press them at same time. Why can’t it be press one key then the other. It is just frustrating to try and get it to work when I need it and then I give up and just open it from the icon on my status bar.


#4

Hello @lwetzel

Are you able to consistently get secret agent to appear now? All keys to the global hot key must be pressed down together to trigger secret agent, otherwise keyboard hooking will not work correctly which causes issues with other applications and system utilities that also present global keyboard shortcuts as well.


#5

Seems to be consistently responding now. Tomorrow it may not.


#6

On my Original Surface Pro it is essentially non functional using the keyboard. Might as well just click the icon.


#7

Hello @lwetzel

Out of curiosity, what type of keyboard do you have connected to your Surface Pro? Is it the Surface keyboard, or a different keyboard?


#8

It is the Surface Type Cover keyboard.


#9

Hi @lwetzel

Could you share what version of STRIP for Windows you are running? Could you check the task bar and confirm STRIP is running when the global hot key does not work? Thanks!


#10

The version of STRIP I am using is 2.4.10.0.

Yes STRIP is running and on the task bar when the global hot key does not work.


#11

Hi @lwetzel

Are you able to plug in a different external keyboard via a USB cable? If so, I would be curious if you see the same behavior with a different keyboard?


#12

I tried a USB keyboard and it works. One thing I noticed is that the Surface keyboard only has one ALT key. The USB keyboard has a right and left. Did have to set the preferences to use the Left CRTL + Left ALT + .


#13

Hello @lwetzel

We are glad to hear it worked with an alternative keyboard. The default hot key binding is a Left Shift + Left Control + \.


#14

So that is it? Use another keyboard? Hmmm. Been using this application since it was a Palm Pilot app. Now I have to use another keyboard to solve the problem with the app.


#15

Hi @lwetzel

We haven’t forgotten about you, however we have been unable to reproduce the scenario you are describing with any of the keyboards we use, nor have we received another report of a similar occurrence. We will certainly keep an eye on this, however being able to reproduce it would be a key component in attempting to fix anything on our side.


#16

I assume you have access to the same hardware I am using. I understand being able to reproduce the problem Wish you were here I could do that for you but, alas not possible. I have installed USB keyboard to my docking station and that works. It just doesn’t whenever I have the surface keyboard.


#17

Hi @lwetzel ,

Stephen Lombardo here, we’ve chatted many times in the past.

One of the difficulties here is that we don’t have an original first generation Surface Pro with Keyboard kit to test with. That said, we have tested internally here on three different windows 8.1 systems, using 5 different keyboards from different manufactures, all with different interfaces, including integrated, USB, and Bluetooth. None of these have exhibited a problem. Unfortunately, we haven’t heard from any other users about this issue either.

There are a few options for pursuing this further.

This might be a long shot, but I wonder if it’s possible that there might be an issue with the keyboard you are using, since it seems to work correctly with another keyboard on the same computer. Do you by any chance have access to a second Surface keyboard you could try to determine if it is actually a hardware problem? This would provide a great data point and help us narrow things down as a first step.

If not, since this is happening inconsistently for you, if you happen to identify any prerequisite conditions that cause it to occur that would be a great help (e.g. if it happens after returning from sleep, after enabling the keyboard, or when the battery is low, etc).

Finally, as a last resort we could look into creating a special debug build that would include diagnostic and tracing information for the hotkey keyboard codes. This would require some time for us to put together on our end, though, and it might not provide any hints.

Let us know what you think. Thanks!