Secret Agent Not Working Windows 10


#1

Secret Agent is flaky. Sometimes it works and sometimes not. It’s fine on my MacBookPro. Without this feature it does not make sense for me to buy the product.

Below is a message I sent to support earlier. Any help greatly appreciated.

Happy New Year!
Well I decided to take today and do the plunge: migrate my PIM data to Codebook so my wife no longer has to figure out cryptic passwords. I have about 72 phone numbers and less than 100 websites migrated in. Two different website entries are set up with username and password. My system is below for reference, it’s a brand new Windows 10 installation on a killer motherboard with oodles of everything.

I have not changed the default Secret Agent key. I have restarted the machine. The run at startup checkbox is checked.

The speed key is flaky. Sometimes it works and sometimes it doesn’t. I have yet to be able to do this two or more times in succession:

Hotkey -> find entry and load url -> navigate to login and choose username -> hotkey->arrow down to username hit enter -> tab for password -> hotkey -> down arrow to select password hit enter -> hit enter to load the page.

I have tried the following:
Chrome with new tab
Chrome with new window
Closing Chrome, hotkey to get Secret Agent up then use secret agent to load a fresh website.

On Edge the thing just doesn’t work. Edge blocks it.

So, on Windows 10 it appears that this application is unusable.

Any advice appreciated.

Best regards,
Bill

OS Name Microsoft Windows 10 Pro
Version 10.0.14393 Build 14393
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name BILL-I7X58
System Manufacturer System manufacturer
System Model System Product Name
System Type x64-based PC
System SKU SKU
Processor Intel® Core™ i7-6700 CPU @ 3.40GHz, 3401 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 2003, 9/19/2016
SMBIOS Version 3.0
Embedded Controller Version 255.255
BIOS Mode Legacy
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Model Not Available
BaseBoard Name Base Board
Platform Role Desktop
Secure Boot State Unsupported
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "10.0.14393.206"
User Name bill-i7x58\bill
Time Zone Eastern Standard Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.9 GB
Available Physical Memory 13.2 GB
Total Virtual Memory 31.9 GB
Available Virtual Memory 29.2 GB
Page File Space 16.0 GB
Page File C:\pagefile.sys
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware No
Hyper-V - Data Execution Protection Yes


#2

Hi @btribley

Thank you for your support of Codebook. We are aware of the current limitation when using Secret Agent with Microsoft Edge, an issue we would like to address in a future release. I have also just responded to your private support message. Please feel free to get back to us at your convenience. Thanks!


#3

Hi @developernotes

I have a similar issue with Secret Agent since I upgraded from Windows 8 to Windows 10, wich means I’m unhappy with CodeBook since several months.

I easily figured out, that Secret Agent is not working with Edge so I switched to Internet Explorer as default browser. Since then Secret Agent seemed to work sporadically. It took a while until I figured out the error systematic, which is as follows:

  • Secret Agent works (after fresh computer start) as long as I only open SecretAgent via hot key from an already open web page.
  • Secret Agent stops working as soon as I open a new web page (e.g. login page) out of Secret Agent (out of a CodeBook website field).

Once Secret Agent “stopped working”, it cannot be opened anymore with the hot key.
Once Secret Agent “stopped working”, it still can be opend via the context menu entry from the tray icon but then it is just an useless window because it is not possible to apply any content into an open web page field.

Exiting Codebook via tray icon context menu and restarting Codebook fixes the issue (until again a web page was opened out of Seret Agent)

This happens with InternetExplorer (version 11.576.14393.0IC) as well as with Chrome (version 55.0.2883.87). So it does not matter which one I choose as default bowser, Secret Agent under Windows 10 is only usable with special care.

Remark:
Since Secret Agent runs into trouble after implicitely starting a new browser process, this looks like it has to do with privileges. Running Codebook with Aministrator privileges seems to fix the issue and this may also be the reason why this issue was not encountered at zetetic developement.

Regards,
Steffen


#4

Hi Steffen,

I have been a big Chrome fan until tonight when I found it was a virus container. I ditched Chrome, made FireFox my default browser then changed the codebook hotkey to leftControl+Divide (the forward slash on the numeric keypad). Problem solved, whenever I hit the hotkey the application comes up. I am guardedly optimistic, the next few days will prove whether this is fleeting or not.

Have fun!

Bill


#5

Hello @Steffen_Hanke

Displaying the Secret Agent window should occur regardless of whether or not it can insert content. For example, it should be able to display the Secret Agent window when the focus is within Microsoft Edge, even though it currently cannot insert content into Edge. It may be that your system has a conflict with the global shortcut used to activate Secret Agent. It may be worth trying to rule this out. When you have the opportunity, login to Codebook for Windows and navigate to the File → Preferences menu. Within preferences, there is an editor that will allow you to reassign the shortcut used to activate Secret Agent. Please try setting this to a different keystroke to see if the behavior changes for you. Thanks!


#6

Hi, I am also experiencing issues with Windows 10 and Microsoft Edge.

I am experiencing the same issue reported by the OP - that Secret Agent simply doesn’t enter any text into fields on Edge.

I can see this thread is nearly a month old now. Is there a timescale for this to be fixed?


#7

Hello @LordScree

We plan to make a release later this week that will include support for inserting content from Secret Agent into Microsoft Edge. :slight_smile:


#8

Awesome! Thank you for the update!


#9

Just came on to say thanks - I got the update a week or so ago and it’s all working well on Edge.


#10

Hi @LordScree

We are glad to hear Secret Agent is working well for you in Microsoft Edge!