Key Binding problem with Windows Input languages


#1

Hi guys, yesterday I found and installed new version which included this new STRIP agent. After this I noticed that my INPUT languages on windows stop working. Since I am Bulgarian - I use BG / US keyboard which I switch with LeftALT + Left Shift. When STRIP is enabled now - this combination no londer works. I tried to change it from windows - but it does not work with other combination too. The monent I exit strip with right mouse click on clock area - Input laguages start working right away. I found preferences menu in STRIP also and change key combination - it still don’t work for me.

Also I did not found any way to disable this behaviour like it was before - is there any option to disable this agent - or to fix my keyboard problem.


#2

Hello @cdman

We would recommend changing the key binding within STRIP for Windows, may I ask what you changed it to such that it still caused a conflict? Could you try using the Windows key as a key binding modifier within STRIP for Windows?

There is an option within the preferences window to disable secret agent from running at login, however it will still be active when STRIP is running.


#3

I changed STRIP combo as LEFT CTRL + 1 or LEFT CTRL + 2 for example - but it still prevents me from using LEFT CTRL + LEFT SHIFT for my keyboard.


#4

Hello @cdman

Could you try changing the key binding to use the Windows key instead of the Ctrl key? Could you let us know your results? Thanks!


#5

OK , I just did :slight_smile: and have new discover. I tried both Combination WinK + A and LEFT CTRL + 1

If I enable STRIP Search Window with one of these - I can switch my Windows Keyboard. If I hit ESC key and STRIP search Window dissapears - then my Windows Keyboard switch stops - no matter of STRIP combo keys.

So it seems when it hides down in the clock area - it blocks other combinations.


#6

Hello @cdman

Is the Esc key tied to something else on your computer? The Esc key should only dismiss the secret agent window when it is visible.


#7

Nope , I use no other bindings. Same happens when I don’t use ESC but click with mouse somewhere else around STRIP search. This way Search Line goes OFF Focus and my windows keyboard switch stops working again. When I close it with rightmouse click from the clock area - my Windows combination works fine.


#8

Hello @cdman,

Could you explain what you mean by Windows keyboard switch, I’d like to make sure I understand the problem you are seeing. Thanks!


#9

Yes, sorry for that misunderstood :slight_smile:

I am using 2 virtual keyboards on my Windows. One is US , other is BG ( Bulgarian ) so I switch between them with LEFT ALT + LEFT SHIFT - as this is standart combination for windows.

I am using Windows7 64bit - short path to this setting is - Control panel - Clock Language and Region - Change Keyboard or other input methods - After this you see a button named: Change keyboards and there you have: Advanced key settings which shows this.

I guess this is used for every non-English native person for switching between US and their local keyboards.