Secret Agent Actions on Windows


#1

hi - on the latest Codebook for Windows installed today on a new hire’s PC, we have Codebook basically up and running, but, Secret Agent Actions don’t work. How do we get that to work? We saw somewhere to “type in anything” after the setup of the label, but, nothing comes out, like it does on the Mac version.

How are we supposed to get Actions on Windows?

Please advise.
–Rick


#2

Hi
I am the one who is trying to get this working.
Please could you advise me to resolve this issue?
Thank you.

Regards,


#3

Hi @rickcogley, @Daiki_Ebi,

I’m sorry to hear you are experiencing an issue with Secret Agent. The default keybinding for Secret Agent in Windows is LeftShift + LeftCtrl + \, is that what you are pressing? Within the preferences window (i.e., File → Preferences menu) there is a checkbox to enable Secret Agent at Windows login, and an editor to change the keybinding. Would you make sure the checkbox for running at login is checked? Without running at login checked, Secret Agent would only work when Codebook for Windows is running. Also, if the default keybinding does not work, it may be due to a conflict with another application, if so, you can try changing the binding to a different value. Would you give that a try and let us know if it addresses the issue? Thanks!


#4

Hi Nick. That works. We can’t get the “macros” to appear. On mac you press down arrow iirc but for win, the drop down never shows.


#5

Hello @rickcogley

I apologize for the previous response, I misread the mention of the agent action. Currently, Codebook for Windows does not automatically provide autocomplete templates for Secret Agent Actions like Codebook for Mac does, this is something we would like to address in a future release.

Once you have created a new label with the mode set to Secret Agent Action, please add a field to the desired entry with your secret agent action label, setting the value to the following pattern as an example:

#[username]<tab>#[password]<enter>

Would you then try selecting that field within Secret Agent, it should properly activate the action for you. Again, we look to improve the Secret Agent Action feature within Codebook for Windows in a future release.


#6

Ok, no problem, Nick @developernotes , so we have to type it in.
Is there a list of all the actions somewhere?


#7

Hi @rickcogley

Here’s a link to the preliminary documentation for Codebook for Mac (also applicable to Codebook for Windows): https://www.zetetic.net/codebook/secretagent/ under “Helpful Tips and Suggestions” it lists all the template actions as well as the available functions – <tab>, <enter>, <waitN>, and <space> and general format for creating any custom actions.

Cheers,
Micah


#8

perfect @mmoore, thanks!


#9

Thank you for your thorough advice!
I`ll try it out.


#10

Hi @Daiki_Ebi, @rickcogley,

Just a quick update, we have released an update to Codebook for Windows that should address the autocomplete issue you were experiencing. More details can be found here. Thanks!


#11

thanks Nick! @developernotes