Windows secret agent

#1

Back when version 3.0.39 came out it broke the secret agent function for me. I have been using crtl+shift+z to bring up the secret agent to login to various sites. After I updated to 3.0.39 secret agent is now entering Z twice so when it brings up the agent it automatically entering the Z before my password causing the login to fail. I’ve sent in a video a video demonstrating this but haven’t seen a patch to fix this yet. This is also reproducible for me across multiple windows machines with different OS version, hardware, manufacturer, keyboards and mice are all different but the problem always remains the same, it will enter the Z ahead of the password causing login failures. I also prefer to us a macros on my mice to bring up the secret agent as it might its that much easier to fill in the credentials. But it usually doesn’t matter which method i use, macro or keyboard presses it will always enter this Z before the password. The email I just received about updating to the latest 3.0.39 just reminder me that i’m still stuck on version 3.0.36. Some news on a update for windows or a patch to fix this issue would be great to hear about.

Link to the video demonstrating the issue.

0 Likes

#2

Video

0 Likes

#3

Hi @Andy_Shuke

Thanks for reaching out again about this issue and sharing the video. I have a few follow-up questions:

  • Does this behavior happen with other programs other than your Internet browser?
  • Does the behavior change if you utilize a different hotkey within Codebook for Windows to trigger Secret Agent?
0 Likes

#4

Nope still doesn’t work regardless of what the shortcut is or what I’m trying to enter the credentials in.Also I noticed half my apps the secret agent doesn’t work with so i mainly just use it for web browsers.

New Video with the changed shortcut…

0 Likes

#5

Hi @Andy_Shuke

Thanks for the additional information. Would you try assigning a non alphabetic character to the Secret Agent hotkey and let us know if the behavior is the same. The default keybinding on Windows is Ctrl + Shift + \. Also, would you try running Codebook on Windows without any other 3rd party applications running in either the background or foreground and let us know if the behavior changes. Finally, would you share what mouse you are using along with the software for defining a macro from it? Is this the same mouse you use at home and work? Thanks!

0 Likes

#6

I changed the secret agent call back to the default and closed all software except for sophos and called it manually with the keyboard. It popped up and was working normal without the \ showing up as a new search when I bring it up the 2nd time. I then restarted all my software that normally runs and used the macro button with the new call and it is working without any issues.

This is good it’s working but the reason I choose to use crtl+shift+Z is because I don’t always use the macro on my mouse and will do it manually and with this key combo it’s very quick to bring up. But using the default isn’t as quick as microsoft found out after adding crtl+alt + del to unlock a pc, it doesn’t feel natural and takes you second hand away from the mouse so getting it to work with my combo would be preferred.

The latest video and test was done on my lenovo laptop that has no special software installed on it. Those test were done with pretty much nothing running except for the bandicam software and antivirus.

PCs im using:

1- lenovo laptop - no attached keyboard or mouse and no 3rd party software except for sophos home antivirus which was installed after this problem with CB. Windows 10 Pro.

2- Dell Vostro - Roccat swarm software for macros creation and use with the roccat nyth mouse. Razer blackwidow keyboard and razer synapse software. Windows 10 Home.

3 - Dell aurora R7 - razer naga chroma mouse black widow ultimate keyboard with macro creation and setup through razer synapse software. Windows 10 Home.

4- Dell workstation - no 3rd party software or special mouse or keyboard. only AV, dropbox and google drive software running in background. Windows 7 Pro.

5- Custom PC - razer naga chroma mouse with macro creation and setup through razer synapse software. Windows 10 Pro.

The latest video and test was done on my lenovo laptop that has no special software installed on it. Those test were done with pretty much nothing running except for the bandicam software and antivirus.

0 Likes

#7

Hi @Andy_Shuke

Thank you for trying out those scenarios, that is good to hear the default keybinding is operating correctly. We will certainly look into this further, thank you again for providing the detailed information about the computer and mouse/keyboard setups.

0 Likes