Update to 3.2.5 from 3.2.1 - No options or Unlock prompt available


#1

A typical upgrade when prompted for available updates.

After download, and without old version running. Installed new 3.2.5 version into Applications Folder and started.

After starting, only a basic Codebook Application window was presented.
No prompt to Unlock the database.
No options available within any menu option. All menu items are grey.

Forced to reinstall ver 3.2.1

Tried several times with the consistent results.

Standing by for someone else to reproduce issue.

I am running OS X Yosemite 10.10.5


#2

Hi @damikey

Thank you for using Codebook and contacting us, although I’m sorry to hear about the trouble with upgrading. Could I ask what macOS you’re running?

Cheers,
Micah


#3

OS X Yosemite 10.10.5


#4

@damikey

I just re-tested 3.2.5 on my 10.10.5 Yosemite VM, and I wasn’t able to reproduce this issue. I was wondering if you could try this out:

  1. Sync your current database (if you haven’t already).
  2. Take a Backup under File → Backups.
  3. Quit Codebook.
  4. Open Finder and Go → Go to Folder and type in this location: ~/Library/Containers/net.zetetic.Strip.mac/Data/Library/Application Support/Strip There should be a default.strip package and a “Backups” folder in that location. Please move those outside of that folder (onto the Desktop is fine for now).
  5. Re-download the update to Codebook here: https://www.zetetic.net/downloads/codebook/osx/Codebook.zip
  6. Unzip it (if your browser doesn’t already do this automatically) and move it into the Applications folder. Attempt to launch it again. It should bring you through the “Getting Started” prompts to setup a new database. Set it up with the same master password as you used previously.
  7. If this runs properly, restore from your synced copy. If it doesn’t, would you mind please taking a screenshot of what you’re seeing?

Thanks!

Cheers,
Micah


#5

Micah,

Completed those steps, but still receive the blank window.
No “Getting Started” prompts and no menu options.

There are no hidden windows or dialogue boxes that I can find.

Screen shot attached.

Reverting back to 3.2.1 it works again.

Screen shot attached.


#6

Micha,

I only moved strip.db, not the entire back directory.

After moving Backups and default.strip it started.
Now the new version started with “Getting Started”.

I then put back the Backups and default.strip and it works on 3.2.5

I had to go back and select my preferred SYNC option.

I’ve never had to do that with any upgrade so far, so it seemed weird.


#7

Micha,

Not stable for me. I had to revert back to 3.2.1 again.

I will try a fresh install later and update back.


#8

@damikey

Could you try running the integrity check on your database when using 3.2.1 prior to updating to 3.2.5? This option can be found under File --> Integrity check.

Not stable for me. I had to revert back to 3.2.1 again.

What was occurring?

Cheers,
Micah


#9

Integrity check -> no problems found


#10

Micha,

I thought I got the updated 3.2.5 working, but it was still 3.2.1.

I still get no prompt for “Getting Started” with 3.2.5

three screen shots.

1st Open

After clicking menu

Reverting back to 3.2.1 to get it to work


#11

@damikey

Could you bring up the Console and see if there are any messages related to Codebook when opening Codebook 3.2.5?

Console can be found under Utilities or through Spotlight search.

Cheers,
Micah


#12

@damikey

After further investigation today, I believe i’ve figured out the problem – it’s related to the updated Google Drive SDK in the new version.

We’re still investigating what we can do to resolve the issue, but I have a solution that should immediately fix the issue for you:

  1. Launch Codebook version 3.2.1
  2. Go to Sync Menu → Unlink Google Drive ([your account here]).
  3. Install the 3.2.5 update, re-link your Google Drive account, and you should be good to go.

Thank you for trying all the suggestions I outlined previously, and sorry for the trouble in the first place.

Please let me know if these steps allow the 3.2.5 update to run properly for you.

Cheers,
Micah


#13

Micha,

That worked!
I am on Version 3.2.5(463) now.

Thank you very much


#14

@damikey

Excellent! Glad I could help.

For anyone else experiencing the same problem, we currently testing a beta version which should resolve the issue --Please reach out to us at support@zetetic.net if you’d like to try it out.

Cheers,
Micah