Upgrade or reinstall with Windows triggers error on first launch

Yesterday I saw the upgrade prompt for Codebook 4. I proceeded to do so on WIndows 8.1. Then the new version was launched. Immediately it prompts for the standard 4.0 sync key question, and simultaneously there is a notice “Codebook has a problem and must be closed” or similar. It is a standard Windows prompt for a dying application. This is reproducible on my system. If I try installer with repair, no difference. If I remove the application and install again from a fresh installer download, the same crash happens on first launch. It’s dead in the water on Windows. The upgrade on iPhone is working OK. What’s the next step to getting this functional/running on the Windows system. I had written email to support and no answer yet. It is rather freaky to have anything unstable happen with such important software.

@labradort Thanks for writing in to us about Codebook and sorry to hear about the trouble with Codebook 4. Can you try checking that the Bonjour service is running under Task Manager and Services tab. If not start the service and then try and run the app. If your still having a problem, please get in touch with us over at support@zetetic.net, thanks!

Cheers,
Don

Hi @labradort

Would you check to see if you have a crash report on your local machine? You can paste the path below in Windows File Explorer, press enter and it will expand.

%APPDATA%\Zetetic LLC\Strip\crashes

If there is a crash file from your recent run of the application, would you mind sending it over to us at support@zetetic.net for further review? Thanks!

Hi,

I didn't get a response earlier today and started a discussion
on the forums.  Someone suggested the Bonjour service
must be running, and that's what the problem was.  So I guess
maybe that's a bug that it would be better to print an error
about the service not being up rather than crash.

The application also updated again today so it might be fixed

already.

Regards,

It looks like your answer was right on. However still a bug there because it should say what the problem was rather than crash. But my issue is resolved now. Thanks very much.

Also, tried the File Explorer path and it comes back not found.
Maybe it is gone

since the program is running alright again...

Hello @labradort - thank you for getting back to us to let us know that starting the service worked for you. You are absolutely correct about the crash, we’ll be releasing an update shortly that permanently resolves that problem.