Cannot Copy from any field of the STRIP


#1

After updating to the latest version today, i cannot copy passwords or any values from any fields of the STRIP

any idea how to fix it? it’s annoying if password manager cannot allow pasting passwords


#2

Hi @AlexPTY, sorry to hear about the trouble! A few questions here to help figure out what’s going on:

  • Can you tell us how you’re attempting the copy? (e.g. Clicking on the Edit menu item Copy, clicking on the toolbar button, typing command+C)?
  • Can you tell us which version of STRIP you’re using (i.e. Android, iOS, OS X, Windows)?

#3

Hello, thank you for attention to my problem. i am using Windows 8.1 version on 2 different PC and 1 windows tablet (all 3 have a copy problem) and Android Phone ( no problem on this one).

the way i do that is opening record, hit “Edit” highlight password or anything in a field with the mice, right click and press “copy” which doesn’t work when i try to paste the same content even inside the field or on Word…

Strip version is 2.4.0.0


#4

Hello @AlexPTY

STRIP for Windows provides a few different options for copy field data to your clipboard. Without entering the edit mode for a given entry, any selected field (highlighted in blue) can have its content copied directly to the clipboard by pressing Ctrl+C. This option is can also be triggered via the Edit → Copy menu item. I was not able to reproduce the problem you were seeing when selecting copy via the context menu while in the edit mode, it successfully copied the value on Windows 8.1 Can you try any of the other copy options to see if they work for you as well? Do you happen to have any other 3rd party applications, such as a clipboard manager running on your machine? Thanks!


#5

keyboard shortcut copy works, thanks. consider it resolved, but right click copy doesn’t, but it’s not a problem

thanks for your help


#6

Hi @AlexPTY,

We are glad to hear you are able to copy via the keyboard shortcuts. We will continue to test internally to see if we are able to repeat the behavior you mentioned above, although at this point we have been unable to reproduce it.


#7

sorry, it came back with the few additions. i noticed when STRIP is running in a background, it block some short-keys like CTRL +C, CTRL + V in application such as Outlook 2013, Movie Maker, Excel and few others. Shutting down STRIP and problems go away


#8

Hello @AlexPTY

We will be releasing a fix to address keyboard conflicts occurring when the secret agent is running soon. Thank you for your feedback!


#9

Hello there. are there any updates to fix this problem available yet? it’s been more than 2 month already


#10

Hello @AlexPTY

What version of STRIP for Windows are you running currently? You mentioned above that you were running 2.4.0.0, however we have released several patch releases since that build was released. If you haven’t, could you try updating to the latest version of STRIP for Windows?


#11

my version 2.4.10.0. none of the copy tricks works now


#12

Hello @AlexPTY

While we have not been able to reproduce the copy issue you described above, I was curious if you happen to be running any 3rd party software that might affect the clipboard behavior such as a clipboard manager? Could you try creating a new user account on your machine, run STRIP and attempt to copy a value when logged into the new user account?


#13

Of cause i am running 3rd party software, isnt it a purpose of having computer? I did create different user account and it has same problem. I even reinstalled strip... It's pretty annoying, i am thinking of switching to something more manageable

Sent from my Sony Xperia™ smartphone

---- Nick Parker wrote ----

developernotes

November 24

Hello @AlexPTY

While we have not been able to reproduce the copy issue you described above, I was curious if you happen to be running any 3rd party software that might affect the clipboard behavior such as a clipboard manager? Could you try creating a new user account on your machine, run STRIP and attempt to copy a value when logged into the new user account?

To respond, reply to this email or visit https://discuss.zetetic.net/t/cannot-copy-from-any-field-of-the-strip/80/12 in your browser.


Previous Replies

AlexPTY

November 21

my version 2.4.10.0. none of the copy tricks works now


To respond, reply to this email or visit https://discuss.zetetic.net/t/cannot-copy-from-any-field-of-the-strip/80/12 in your browser.

To unsubscribe from these emails, visit your user preferences.


#14

Hi @AlexPTY,

I was inquiring below as to whether or not you may be running a 3rd
party clipboard manager application as this could be a potential cause
of conflict. Do you have something like that installed on your machine
that interacts with your clipboard?

The reason I ask is because it sounds as if this may be an environmental
issue as we have not received feedback from anyone else exhibiting this
behavior.


#15

@AlexPTY

I’m Stephen, I work with Nick, sorry to hear about the trouble. This may be a real “long shot”, but I was wondering whether you might be running an internet security package on your computer called Webroot SecureAnywhere?

If so, we have had reports from a small number of other users that it can cause problems with copying and pasting with STRIP. Here is a link to an article from Webroot about this issue:

If you are running this software, it’s possible that the re-install triggered the active protection. If that is the case you may be able to fix it under the tab “Identity & Privacy”. You’ll find an an option there called Protected Applications (Advanced). If STRIP is set to den, change it to allow and copy and paste would work again.


#16

Alex, you are a star! I do have Webroot. That said, I re-installed Strip today and after cleaning register values was able to delete license files. Clean uninstall works with all kinds of copy/paste now.

Another issue I would like to bring to your attention. When Strip was uninstalled and re-installed, it did pickup license key from the old installation and connected to backup file on a Dropbox. I do not think it’s a secure option, application uninstall should remove this information from the registry


#17

Hi @AlexPTY

We are glad to hear that resolved your issue. We will look into the uninstall process to see about removing the license key. Thanks!


#18

I was reading through this thread and thought it was interesting.

I’m running STRIP 2.4.3 (265) on my ipad, and see similar behavior when trying to copy fields. I have a 2nd generation ipad MC984LL/A, 64 GB. Not using anything like webroot or clipboard manager sorts of things. Here are some examples of behaviors I encountered, FWIW.

Scenario 1:
At the top level when I choose a category to view a record: after selecting the entry to view the contents of that record (e.g., seeing the email, password, account, info). I’m not actually “Editing” the record, but I can tap on a field, the whole field ‘greys’. I don’t get the traditional ipad selections (to cut, copy, select, etc) but a ‘copy’ bubble does pop-up–I cannot actually ‘select’ what I want to copy. Now, if I exit STRIP and go to some other app (Notes, for example), I can tap and what I just appeared to “copy” gets pasted. So at this level it does seem to capture on the clipboard and be available to paste somewhere else.

Scenario 2:
When I actually choose to ‘edit’ the entry, and I see the red minus-sign circles for each field), at this level I can also tap and hold on a field, the copy bubble shows up and similar behavior as in Scenario 1 happens, e.g., I can exit out of STRIP and paste whatever field I apparently copied into another app.

Scenario 3:
This is the one with surprising behavior for me. At this level, I had expected to be able to tap and select text, have it highlight and perform some action–but not the case.

If I actually “Edit” the entry and move to the next level down (press the “>” character on the right side of the screen to get to the actual field where I can type in or delete text) …I cannot select anything. Even though the bubble pops up giving me the option to select/select all, nothing happens. Nothing gets selected, nor does anything seem to copy (like clipboard) to be pasted elsewhere.

I provide these scenarios to give you additional feedback in case it sheds any further insight. So bottom line, I can get text to copy and be pasted, but only in the 1 & 2 scenarios, not the third…where I’d expect to be able to do it.


#19

Hello @gk_sync - Thanks for letting us know about this issue. The behavior you sounds unexpected for STRIP. May I ask:

  1. are you currently using STRIP for iPad (i.e. it displays in full iPad mode), or STRIP for iPhone (i.e. it displays in compatibility mode, with 1x / 2x zoom)?
  2. What version of iOS are you running?

If you’d prefer, feel free to drop us an email at support@zetetic.net with the details.