Codebook Sync Disabled - Ideas?


#1

Running Codebook Version 3.1.4 (412) on Macbook Pro w/ OSX Sierra and the latest version on my iPhone 6.
When I first set them up a month or so ago they sync’d just fine using WiFi.
Now they won’t sync, phone says timeout, and Sync\Operation shows disabled on the Macbook.
Both devices are on the same WiFi network and work properly otherwise.
Any ideas?
Thanks in advance,
Matt


After 3.6.2 update, Can't sync,
#2

Hi @maslin

This is actually the correct behavior on the Mac side. WiFi sync should always be initiated from the mobile device involved.

To successfully perform a WiFi sync operation, both copies of Codebook need to remain open and unlocked and have the exact same master password.

Here are the steps to perform a WiFi sync:

  1. On Codebook for Mac, go to Codebook Menu → Preferences → Sync Tab, and set the sync preference to “Desktop WiFi”. There should be light gray text at the bottom saying “Listening as (port 57419)” similar to:

  2. On Codebook for iPhone access the sync view through More → Sync, set the mode to Desktop WiFi and tap the Computer row to attempt to find your computer name, currently your sync view should look like this:

  1. Your computer name should show up under the “Local Network” tableview on the next page similar to:

  2. Tap your computer name, which will bring you back to the sync view with your computer name inserted similar to:

  3. Tap start in the upper right hand corner and the sync should begin.

If these steps don’t work, we’ve written up a short set of common troubleshooting instructions here:

Would you mind giving some of the suggestions in this document a try, and let us know what you find?

From your description, since you were previously able to sync over WiFi and are no longer able to, my best guess is that you may just need to restart your router/devices and re-try syncing.


#3

Micah,Thanks for the tips, tried them all but no love. Both the Macbook and iPhone are on the same WiFi network, same master password (I reverified that). Everything has been rebooted multiple times. Before, I could select the Macbook under “browse network” on the iPhone and hit “start” and it would time-out, now Codebook on the iPhone doesn’t see the Macbook at all meaning it doesn’t list it under “browse network”. Is it possible the WiFi router is blocking something? If so how do I fix that. I’m using a TP-Link AC1750 Wireless Dual Band Gigabit Router. Matt


#4

@maslin

Thanks for trying out those suggestions, and sorry none of them worked. Frequently when the iPhone can’t “See” the computer on browse network something is blocking it. Most of the time we find that a firewall or anti-virus protection is the cause. Do you have any firewalls or anti-virus running? It may be worth checking if your built in OS X firewall is enabled/blocking as well. Here are some instructions from apple about where to find it and how to enable/allow certain programs access: https://support.apple.com/en-us/HT201642

You mentioned your router, did you recently replace it? Have you attempted to manually specify the IP address of your computer? – Those instructions can be found under “Sync without Bonjour/Zeroconf/mDNS” in the Troubleshooting Wifi post