Desktop Sync Problem


#1

When I try to sync with Dropbox it gets to 90% and after a while a small square window opens saying “A task was Cancelled” Any ideas?


#2

Hello @u752181

Thank you for your support of Codebook, although I’m sorry to hear about the behavior you are experiencing. I have a few follow-up questions:

  1. Is this for Codebook on macOS, or Windows?
  2. What version of Codebook do you have installed on your machine?
  3. Have you previously synchronized successfully with Dropbox on this machine?

#3

I’m having the same problem with Dropbox syncing.

Codebook for Windows 3.0.32.0
Windows 10
I have synced before, but I can’t remember if I’ve synced since the last update was released.
I tried deleting the existing backup file on Dropbox, but that still results in the error.

I tried adding Google Drive support, and that failed during sync at 90% with an equally perplexing answer: “The request has aborted. The request was canceled.”

I have Codebook for Mac and iOS as well, and have no problem syncing to the accounts with those versions of the program.


#4

Hi @bobmhac

I tried deleting the existing backup file on Dropbox, but that still results in the error.

If you have not tried this yet, would you unlink your Dropbox account? This can be performed in the File → Preferences menu, click the unlink button. Once you do this, attempt another synchronization. You will be required to authenticate with Dropbox with this attempt. Would you give that a try and let us know your results?


#5

I should have mentioned I tried that. I unlinked Dropbox and relinked, and still received the same peculiar error message.

However, now that I’ve tattled on it, the software seems to have regained sync functionality again. I use codebook on my work computer. The only thing I can think of that would transient in that fashion is our IT team has been configuring a new firewall. Might have been something there. Otherwise, it seems to be working again. If it happens again, I might bug you guys for some port/protocols and such.


#6

Hi @bobmhac

Glad to hear everything is working properly. All Dropbox/Google Drive communication should occur over port 443, while local WiFi synchronization occurs on port 57419. Please let us know if you run into any other issues. Thanks!