IOS Sync>Start Sync Does nothing


#1

HI. Suddenly my sync on iMac (macOS High Sierra Version 10.13.2) is doing nothing when I click on the Start Sync. It is working on my iPhone 7+ (iOS version 11.2.1). Sync file is in Dropbox. It has worked in the past.


#2

@clo2peter

Thanks for your support of Codebook, and for posting here, although I’m sorry to hear about the troubles syncing with Dropbox.

Could you verify that Dropbox is selected under Codebook → Preferences → Sync Tab? We’ve seen an issue recently on macOS High Sierra where user’s preferences are getting lost.

If Dropbox is already selected, could you try unlinking and relinking. You can unlink under Sync Menu → Unlink (account name), then attempt to start a sync operation again and it should prompt you to login with your Dropbox credentials again and “Allow” Codebook.

Let me know if either of these suggestions allow you to sync again. Thanks!

Cheers,
Micah


#3

Hi Micah. Yes Dropbox is selected in Preferences>Sync Tab.
There is no Option to unlink under Sync, only
Operation>
Start Sync
Under Operation there is
Sync with Dropbox (selected)
Restore from Dropbox
Overwrite Dropbox


#4

@clo2peter

Could you try temporarily selecting another sync preference (Google Drive for example) in Codebook → Preferences → Sync Tab then switching back to Dropbox to see if it will reload your account?

Did you have your Dropbox account previously linked with Codebook for macOS (I’m assuming so since you mentioned you were able to sync with it previously)?

Could you also let me know which version of Codebook for macOS you’re using. This can be found under Codebook → About. Thanks!


#5

Version 3.1.0 (398)
Yes, I have been using for a long time, and as I said, it has worked before and works fine on my iPhone
I tried selecting Google Drive, nothing happened.
I switched back to Dropbox, nothing happened.
Tried syncing, nothing happened!


#6

@clo2peter

You seem to be using an older version of Codebook. Could you update to the latest version: Codebook for macOS 3.3.3 Released

I believe that version used Dropbox API v1 (which has now been fully deprecated). All the newer version of Codebook use Dropbox API v2.

Let me know if updating to the latest version resolves the issue for you.


#7

OK, I’ll give it a try now


#8

Great, all working now. I did have “Check for Updates Daily” turned on but it obviously wasn’t working!

Thanks for all your help, great support!


#9

@clo2peter

Great. Glad I could help. Although that is puzzling that you didn’t receive notification of updates even though the preference was checked. We should be doing another release of Codebook for macOS this week. I’ll try to remember to post back here to check if you received notification of the update alright


#10

@clo2peter

We released Codebook for macOS 3.5.0 yesterday I just wanted to check back in with you to see if you were notified of the update properly.


#11

Yes I was and have updated.

Thanks again


#12

@clo2peter

Excellent. Have a nice holiday!