iOS Will not sync

I have Codebook on 4 machines. For over one month, my iPhone ( Model 12 iOS vs. 14.6) will not sync to dropbox while all other machines will. I even removed Codebook today, reloaded it from the App-store (vs. 4.4.3) and then added the phone as a new device and tried to sync. It failed with the same error message: “codebook-changesets-3640.db couldn’t be removed. The file doesn’t exist.” Well, it does exist in dropbox and is shared properly. When I rename or remove it from the Shards folder then sync fails to find it to use. This is a changeset from early May. What do I do to get my phone sync’ing again?

Hey @MichaelPetersonSBCA

Thank you for your support of Codebook and for posting to the discussion forum, although I’m sorry for the trouble. It sounds like something may have gone awry with your sync state. Let’s try these steps:

  1. Enable Sync Operations on the device which you believe to be most up-to-date by following these instructions: Codebook Help - Sync Operations
  2. On that same device, set the Operation to Overwrite and start the Overwrite.
  3. On every other device you’re syncing with, enable sync operations by following these steps: Codebook Help - Sync Operations
  4. Set the operation to Merge and start the Merge. Choose Google Drive or Dropbox as the conflict authority.

Note: Choosing the conflict authority doesn’t choose all the data from one device, it’s only used in edge cases where the Standard conflict resolution can’t determine which record was updated more recently as described here: Codebook Help - Sync Operations

After performing these steps, make a test change and perform a standard sync operation to confirm that it syncs properly.

Please let me know the results. I’ll be happy to help if you have any questions or run into any issues along the way. Thanks!

Thank you. Simple and worked just fine.


Excellent news. Glad I could help.

Please feel free to reach out again if you have any further questions, issues, or feedback.