Dropbox sync not working on a new iPad pro

i have codebook on 3 other devices and use dropbox to sync. i’m trying to get the data downloaded to the new iPad Pro. I’ve setup the Sync Key from my iPhone codebook. When I then sync, it seems to be working but ends up with this error:

“codebook-changesets-3.db” couldn’t be removed.
The file doesn’t exist.

Most times, codebook then closes. On relaunch, none of my data is there.

The file does exist on dropbox, along with lots of other changesets files.

Hi @manelson.us

Thank you for using Codebook and reaching out, although I’m sorry to hear about the trouble with iPad Pro failing to sync. Could you please write into us at support@zetetic.net so we can assist. Thanks!

Hi - this began occurring with me on Google drive today. iOS13.4.1, both on an iPhone 8+ and on a 7 - Codebook 4.0.14 (870). The process gets to about 56% (18/19 files), then appears to stall. Progress bar closes, and the error pops up (“codebook-changesets-569.db” couldn’t be removed. The file doesn’t exist.). The database appears intact on the phone, but is not updated. The same happens when trying to update the database on my laptop (W10 - Codebook v with the exception that there is no error message, and it goes to 75%before the progress dialog snaps closed - there is no propagation of updates to the target machine. I was able to use WiFi sync from my main machine to the two iPhones, and then from one of the iPhones to the laptop - went without a hitch. Still not able to use sync to Google drive even after manually syncing with WiFi, and re-syncing to Google Drive.

Per triage, I tried restarting the iPhone 8+, and I performed an integrity check on the main machine’s database. Neither affected action this issue.

Per your advice to maneson.us, I will also include this in an email to support. However, also putting it in the forum helps others - like me - find the issue if they’re experiencing it, and is also the best place for you to publish advice or solution for the self-motivated… Like they say: you can’t manage a secret!

Hey @pbabcock

Thanks very much for using Codebook and reaching out, although I’m sorry for the trouble you experienced during sync. We’ve responded separately to your support request which I believe has resolved the issue for you. Because many factors can come into play depending on which devices and sync providers are used, we feel that it’s better to handle this on a case by case basis with guided support rather than publishing a blanket set of steps (which may not work for every case).

There are some improvements coming in the next release of Codebook which should both prevent the issue you experienced from occurring and allow recovery to be greatly simplified. There’s a link to sign up to test the next version within the discussion post above. We should begin external beta testing shortly.

Not to be impertinent, but, last I checked, Codebook is available for Windows, MacOS, iOS, and Android, and syncs between Dropbox, Google Drive, desktop WiFi, or to a csv file. That is a pretty finite set of devices and sync providers. Still, the solution revealed to me did amount to the steps one must have had to use to get into a speakeasy during prohibition, so I get that it probably wouldn’t be for general consumption…