Sync to Dropbox Suddenly Failing


#1

Hi, I have long been able to sync Codebook to Dropbox or Google Drive with no problems (well, at least none in the last six months–it is still too slow of a process, especially from an iOS device on a slow internet connection), but, suddenly, I got this error: Unable to Upload Sync Data. The operation couldn’t be completed. No such file or directory,
I got this error while trying a normal sync from my Mac (running Mojave 10.13.6) with Codebook 3.6.6 (574). I had last sync’d successfully yesterday. I tried an overwrite sync but that also failed with the same problem. I checked my Dropbox folder and Dropbox sync’d normally to my computer. The Zetetic folder was present and no problems were reported in syncing my entire Dropbox to my machine.
What could be causing this problem? (I will next try to rename my old strip.db and make a new Zetetic folder and see if that does something but I wanted to post this in case this is a wider problem). My Mac OS was last updated over a week ago.


#2

Okay, so I renamed my old strip.db (which is around 50 MB by the way) as well as the old Zetetic folder. I tried an overwrite sync from my desktop and got the same error although, interestingly, an intact new Zetetic folder and strip.db (of about the right size) also showed up in my Dropbox. However, Codebook still reports that the sync failed with the same error message as I posted above.


#3

And, Desktop to iOS device Wifi sync worked for me without an error, but I still do need Dropbox sync to work because I share databases with far-flung family members.


#4

Hi @Newton991,
Thanks for contacting us about Codebook and sorry to hear about the current problem. Can you first run the Integrity Check on the Mac databse and if there are any errors, they should be cleared up. Also, you might want to check how much space you have open in Dropbox before you try the Overwrite and Sync again. Let us know how things go.

Cheers,
Don


#5

Well, I waited a couple of days and tried again and now it works. I am not sure what the problem was. I have plenty of room in Dropbox and the Integrity Check showed no errors. In any case, no problem now.


#6

Hey @Newton991,
Glad to hear that the sync is now working. It is possible that Dropbox was having an issue at the time you were trying the sync. Since your database is quite large, I would recommend compacting it at some point to purge the sync logs included in the database. here are some instructions for doing this: Compact Database Feature

Let us know if you have any other questions.

Cheers,
Don