Problem with sync DROPBOX


#1

Hello, I am using STRIP/Codebook from a long time - more than 3 years. Last week I think there was new version 3.0.22

I am using 2 windows machines + 1 iPhone. What i notice now , I can’t sync with DropBox anymore. It does not give any error. For example i am changing some record - then I give SYNC to dropbox - and right after this operation my record is older version again - even on same computer which I did change before 1 min.

I tried to sync with OVERWRITE Dropbox - same thing. record is older version after this even on master computer.

I tried sync all first - and then Compact database - same thing.

Long story short - at the moment - I can’t make any update to database at all from neither PC.

Any idea what could cause this ?


#2

Hi @cdman

Thank you for your support of Codebook. Would you try unlinking your Dropbox credentials within the File → Preferences menu. Once you do that, when you initiate a sync the next time you will be required to authenticate with Dropbox. Would you try that and let us know your results? Also, we just released an update to Codebook for Windows this morning, the current version is 3.0.23.


#3

I just upgrade with latest 3.0.23, and relinked Dropbox , it’s the same. But I made another test too. I made little change - then SAVE. Then I seach another record, and after that search the edited one. I see old data. So problem is not with Dropbox - but Local with my wallet - it does not save at all.

Any idea how to check that ?


#4

Hello @cdman

Would you mind running the integrity check feature, it is available from the File → Integrity Check menu. Would you share the results reported? Thanks!


#5

Integrity Check complete without issues - that is what it said.

Also here is database information - if it can help.

codebook-info


#6

Hi @cdman

Do you happen to perform the compact database option before or after you performed the overwrite operation? Do you recall when you started see the behavior of the data not synchronizing? Also, to confirm: when you do not perform a synchronization, but do change some data locally, if you close Codebook for Windows and login again, is your change persistent locally?


#7

Hi @cdman

Would you move the strip.db file located in the Zetetic folder on Dropbox to a temporary location. Next, from one of your Windows machines perform and Overwrite operation to Dropbox. On the other Windows machine and iOS device perform a Restore operation. Following that, would you attempt to change some data and see if performing a synchronization works properly replicating the data change for you? We look forward to hearing your results. Thanks!


#8

I did several new tests. So far I can tell Dropbox sync is working fine. The problem is somewhere in my database.

When I change an Item - and press SAVE - I see it changed.
Then I just search for another item, view it and then go back to search the first one. And I still see the old value before the change.

I tried to make new Field with same type “Note” - then copy the data from the original field , and saved. Now all works. It appears that I have problem with my database. I noticed this problem about 1 week ago , before this time I never clicked on compact database or check integrity. Today - since I started to investigate, I clicked check integrity which gave something I did not saved as a picture. After that I clicked compact database on both devices.

Also when I create new record with several fields - all is fine. So problem is just for some OLD records. Since I imported my wallet 3 years ago from CSV , I had many custom field types - not sure if this is issue. But since last week it was never a problem - just mention it. I guess I have several options:

I can closely check old records when change - to double check if change is OK , and if not to duplicate the field.
I can export the whole wallet to CSV and then IMPORT from scratch - but this can lead to some issues I guess :slight_smile:

What would you advise ?


#9

Hello @cdman

It does sound as if something is misbehaving within the database. Since there are multiple devices at play here, I’ve detailed the steps below to reset properly:

  1. On one Windows machine, perform a CSV export of your data when using Codebook for Windows 3.0.23
  2. Close Codebook for Windows
  3. Open the following directory within Windows Explorer:
%APPDATA%\Zetetic LLC\Strip
  1. Temporarliy move settings.db and strip.db to your Desktop
  2. Launch Codebook for Windows on the same machine you performed the export
  3. Set and confirm your master password
  4. Select File → Import, select your CSV file
  5. Verify the imported content looks correct

Next, we need to replicate the new database out to Dropbox and restore that onto your other Windows machine and iOS device:

  1. On the same Windows machine as above, verify in File → Preferences that Dropbox is selected as your synchronization provider
  2. Select the Sync → Overwrite Dropbox menu, you will be required to authenticate with Dropbox
  3. On your other Windows machine (running 3.0.23), login with the same master password set on step 6 above
  4. Select the Sync → Restore from Dropbox menu
  5. Verify your data looks correct again
  6. Repeat the same restore process on Codebook for iOS

Once you have completed these steps, would you then attempt to make a change on one device, perform a synchronization with Dropbox, then synchronize with Dropbox using Codebook on another machine/device and let us know if your data is properly replicating again? If everything is working properly again, you can delete the settings.db and strip.db files on your Desktop.

We look forward to hearing your results. Please let us know if you have any questions along the way.


#10

Confirming suggested plan - all works now. So it was local database issue. Thanks!


#11

Hello @cdman

Great, we are happy to hear everything is working properly now! Take care!