One Codebook, two Dropbox accounts, wrong sync


#1

Hi

I have a personal Codebook (so pleased with it) and two dropbox accounts, one for personal use and another for corporate use. The Codebook is linked to the personal dropbox account, sync works fine with almost all my devices. Unfortunately, linking my Codebook to my Dropbox in my laptop computer I made a mistake and I aproved an autorisation with the wrong account, so it’s liked to the corporate account insted of the personal account.The result is that the sync advances only till 5% and then aborts the operation.

I’ve tried installing and reinstalling Codebook but the mistake is still there.
I’ve revoked the Codebook permit in my Dropbox corporate account but… no way.
Obviouly, If I wipe completely my computer and make a fresh install of everyting, I’ll solve the isue but it’s an extreme I’m tryng to avoid.

Can you help me?

Thanks


#2

Hi @oba

Thank you for your support of Codebook and for posting to the discuss site. Although I’m sorry for the trouble with linking the incorrect Dropbox account on your laptop.

So Codebook stores an authorization token for your Dropbox account when you “Link” it. So we’re going to want to remove this authorization token (that’s associated with your corporate account) from Codebook so that we can “Link” your personal account (and store that authorization token).

I believe you’re using Codebook for Windows, but if you’re using Codebook for macOS the steps are very similar

Here are the steps:

  1. Open and Unlock Codebook.
  2. Go to File → Preferences. There should be an “Unlink” button next to your Dropbox account name. Click the “Unlink” button and your account name and the button should disappear. Select OK to close out of preferences.
    Unlink_Dropbox
  3. Go to Sync Menu → Sync With Dropbox and you should be redirected out to your web browser to enter your Dropbox credentials and link your personal account.

Please let me know if this allows you to link your personal Dropbox on your laptop and complete a sync operation.

Thanks!


#3

Hi mmoore
Thanks for your answer
As far as I see, there is no Unlink button


#4

@oba

Thanks for the response and for the screenshot. There definitely appears to be no Unlink button present!

So when you go to Sync Menu → Start Sync does it re-direct you to your web browser to authenticate with Dropbox? – I’m assuming the answer to this is no, since you mention it just stalls at 5%, but just want to verify.

Also could you let me know which version of Codebook for Windows you’re using? This can be found under Help → About.

Thanks!


#5

You’re right in the 5% issue.
My version is the last one (just downloaded today) 3.0.26.0
X


#6

@oba

What do you have your default web browser set to? This can be found under Settings → Apps → Default Apps. Would you try temporarily switching it to another browser and see if that makes any difference?

Do you already have your web browser open (and perhaps are logged into Dropbox) when you’re attempting to sync?

Thanks!

Cheers,
Micah


#7

Hi Micah
Thanks for your interest in my situation
I’ve proceed as you sugested and I changed my default browser
I’ve turned off dropbox (personal account) as a “background” app (icon on
right down corner).

I’ve started Codebook but the results are the same.

Can you suggest anything else?

Thanks
X


#8

@oba

Let’s try deleting your encrypted settings database and re-creating it.

Here are the steps:

  1. Quit and close Codebook if it’s open.
  2. Open File Explorer and paste this in the address bar: %APPDATA%\Zetetic LLC\Strip
  3. Within that folder there should be a settings.db file, these are your encrypted settings. Move them to the trash.
  4. Open Codebook, login and attempt to sync with Dropbox again. See if it properly redirects you to the web browser to authenticate/link with Dropbox now.

Let me know the results. Thanks!


#9

(Correct answer to your message)

Hi Micah

Great to have you again in my computer after my Christmas holidays

I’ve proceed as you suggested

Certainly, as I delete the settings.db file, It requires my autorisation
again on dropbox

Then, I connect to de correct dropbox account (not the professional one)
and this screen apears.

I accept the allow (permitir) button and another screen apears that says:

Codebook has received the verification code. You may now close this window.

But the sync aborts at the same 5% point.

When I ask again for a sync, the previous screen apears again, I press on
Allow… but the sync doesn’t happens.

Thanks


#10

@oba

Could you check your File → Preferences window and see if there’s a “Unlink” button present now? If so, would you click the “Unlink” button and then attempt to sync with Dropbox again (it should bring you back out to authorize/link with your Dropbox account).

Also do you have a specific firewall/antivirus running? If so, would you mind temporarily disabling it while attempting to link your Dropbox account just to rule out that it’s blocking it.

Thanks!


#11

Hi Again Micah
After you last actualization 3.0.28.0
Problem solved
Thanks
Xavier


#12

@oba

Excellent news. Please feel free to reach out again if you have any further questions issues, or feedback.

Have a good weekend!