Issue syncing after upgrading to Codebook Version 4.4.0 (938) beta

“MacBook Pro contains changes from schema version 23 and your local schema (on my iPhone) is 20. Update Codebook to latest version then retry.” I don’t know how to update on my iPhone since I already have a license.

I have been having the same problem since my Windows PC has been updated with the latest app. Changed preference to “public” on my PC but still same problem(since it’s PC DB schema is already updated?). Syncing between my iphone and Windows PC does not work ever since with the same error message.

Team zetetic got back to me this morning. They sent me instructions on installing their beta Codebook software on my iPhone, and I followed them exactly. I am now able to sync my iPhone to my MacBook. Team dietetic is the best and has been for SEVERAL Years resolving all my issues.

1 Like

Thanks so much, it’s been our pleasure, and I’m glad that we could get you squared away!

@sign We think the best way forward for you right now is to have you install the latest beta on your iPhone, so it can sync with the beta version of Codebook on your PC. Do you use the same email address for the iTunes App Store as you use for the Codebook discussion forum? If so, I can invite you to the beta using that email address.

Yes, it’s same. Thank you.


Great. I’ve just invited you to the iOS TestFlight beta. You should receive an email shortly with instructions on how to download TestFlight and get the beta.

Please let me know if you’re able to get the beta alright and sync successfully again. Thanks!

Hi - having the same problem here. Also not sure why, but the latest public release that I downloaded defaulted to updating on the beta release - which is probably how this problem occured. But I need to update my iphone version so continue to sync. the email address is not the one I’ve used to register on this website.

Hi @BillieSamBob

Would you mind reaching out to us directly at, we would be happy to go over the options available to get your devices syncing again. Thanks!


I’ve tried reaching out to you twice at the email - but have not had any replies. Can you please advise.



We had replied via email to both your support emails within 30 minutes of receiving them. Unfortunately it doesn’t sound like you received either of the replies (perhaps they went to spam?).

I just sent you a private message via discuss and I’ll be happy to assist further within that private message thread.

Hi: I am having the same issue with schema 20 on my ipad and iphone and schema 23 on my Windows laptop. Can you please send me an invite to the iOS beta for Codebook to see if that will update my iOS devices to schema 23? Thanks

Hey @mattsharp

I’ve just invited you to the TestFlight beta for iOS. Please let us know if you’re able to get the beta alright on your iPad/iPhone to update to the latest beta version and sync successfully again.

If you run into any issues, we’ll be happy to help either here on the discussion forum or via private support at


1 Like

Thanks this worked! Can you please send me a second invite so I can load the beta on my iPad?


Glad to hear that worked for your iPhone.

If your iPad is using the same Apple ID as your iPhone, you should be able to just download TestFlight (from the App Store) and the beta should already be available to you within the TestFlight App. If your iPad is using a different Apple ID, please direct message me with the email associated with that Apple ID.

Yes, sir! Worked on the iPad too. Big relief my devices are all sync’ing again. Thanks


Excellent news. Please feel free to reach out again if you have any further questions, issues, or feedback.

Thanks again for using Codebook and beta testing!

When will the official version be published?


The 4.4.0 official version was released on October 6th: Codebook 4.4 Released - Image and PDF Attachments 🥳

We’ve since done a couple of maintenance updates and the latest versions of each platform are listed on this page: Codebook Help - Platform Requirements

If you’re experiencing any difficulties feel free to write us at or create a new post here on the discussion forum and we’ll be happy to help. Thanks!

A post was split to a new topic: Unable to WiFi sync Codebook for macOS + iOS