STRIP stuck in Application Not Responding on El Capitan


#1

I noticed after upgrading my Mac to El Capitan that the app is stuck in Application Not Responding state. I have put application in trash and re-installed from App Store with no change. Really need to get to a password today. Anyone else seen this behavior? Any ideas on how to resolve?

Thanks!


#2

I should note that I cannot see properties of the app in order to get the app version but I downloaded the latest version on the App Store.


#3

Hi @Tori_Wooldridge, sorry to hear about the trouble. We have seen instances where upgrading from older versions of OS X to El Capitan can have this effect. We think it’s something to do with the new System Integrity Protection feature. I think you could resolve it by deleting the application’s container directory so that it will be recreated by OS X on next launch—but before we do that we need to backup your data.

  • If STRIP is still not responding, right-click (control-click) on the application icon in the Dock and select Force Quit
  • In Finder, select the Go menu and “Go to Folder…”
  • Copy and paste the following path into the dialog that appears, it’s all one line:

~/Library/Containers/net.zetetic.Strip.mac/Data/Library/Application Support/

  • In the folder that opens, locate the Strip folder and drag it to your Desktop, it contains your encrypted data
  • Next, select Go to Folder again, and paste: ~/Library/Containers
  • Locate the net.zetetic.Strip.mac folder and drag it to the Trash
  • Empty the Trash
  • Launch STRIP—does the application come up and ask you to set a password?

If it does: quit the app, go back to the ~/Library/Containers/net.zetetic.Strip.mac/Data/Library/Application Support/ folder, and drag your Strip folder from your Desktop back in place, then launch the app again and sign in.

If it does not we can see if it’s a problem with the store agent. Some of our customers have had success resolving that problem by signing out and back in to the App Store app on their Mac, others have used the Terminal command killall -KILL storeaccountd which resets Mac App Store authorization.

Please let us know if that helps.


#4

This worked perfectly! I had to drag the folder back from the desktop to the filepath you specified, but after that I was good to go. I appreciate the quick response and love the product. Thanks!


#5

@Tori_Wooldridge that’s great news, thanks for letting us know it worked!