Sync Key Issues

I have backed up my Sync Key using the “Write Down Word List” option. I have three devices. Now when I attempt to Sync on each device I get the following error message: “Failed to open remote metadata file. Your local Sync Key may not match the Sync Key used to create the metadata file”. Excuse my ignorance but I have no idea what this means. Are you able to help me please?

Hi @Ben_Lathlean

Thanks for using Codebook and posting to the discussion forum, although I’m sorry to hear about the disruption after updating.

Codebook 4 now uses a Sync Key to encrypt synced data. A single Sync Key needs to be shared between all of your devices (i.e. the same one). This error message indicates that there are different Sync Keys on your devices.

If you have one device that’s successfully syncing, let’s keep this device’s Sync Key and we’ll call that device “Master” for the rest of these steps.

Could you please examine the Word Lists on each other device and compare them to Master’s Word List. You can display the Word Lists on each device by following these steps:

If your Sync Keys don’t match, you’ll want to delete the non-matching ones by following these steps:

After, you can lock Codebook and unlock Codebook on the devices where you deleted the sync keys and it will prompt you to set up the Sync Key again. Choose “YES” to import the Sync Key from your Master device by following these steps:

The import instructions/example is under “If you’ve already setup a sync key”
The display instructions/example is under “Displaying Your Sync Key”

Please let me know if these steps allow you to get up and running with the same Sync Key, and sync between your devices.

One other thing to mention is that some of the Word List words are somewhat close (i.e. aptly and apply) if you’re importing your Sync Keys by Word List, please make sure to check carefully that there are none of these “close words” swapped in

I tried the above with no success. I deleted the Sync Key from all my devices then setup a new Sync Key and added this to all devices. When I try to sync on any device I get the same error message i.e. “Failed to open remote metadata file… etc”. I even used the QR code method as well with the same result. I don’t know what else to try


If you’ve deleted your Sync Key from all your devices, you’ll need to clear out your previously synced data (that was encrypted using the Sync Key that’s now deleted).

Here are the instructions depending on which sync method you’re using:

Google Drive:

  1. Login to your Google Drive account with a web browser.
  2. Navigate to the Zetetic folder.
  3. Delete the Shards folder.


  1. Login to your Dropbox account with a web browser.
  2. Navigate to the Zetetic folder.
  3. Delete the Shards folder.


  1. Quit and close Codebook if it’s open.
  2. Open File Explorer and paste this in the address bar: %APPDATA%\Zetetic LLC\Strip
  3. Delete the sync folder.
  1. Quit and close Codebook if it’s open.
  2. Open Finder and access Go menu > Go to Folder and paste this location: ~/Library/Containers/net.zetetic.Strip.mac/Data/Library/Application Support/Strip
  3. Within that location is a default.strip package, right click (ctrl + click) and choose “Show Package Contents”.
  4. Within that package delete the Shards folder.

After you clear out you previously synced data, attempt to sync again and see if it goes through properly this time.

Let me know the results. Thanks!

Awesome. All good. Thanks very much for your help.


Excellent. Glad I could help.

Please feel free to reach out again if you have any further questions, issues, or feedback. Have a happy New Year!