Sync SQL logic error


#1

Since the latest version of Strip that became available to install today on my PC (v2.4.10.0), I can no longer sync (with Google Drive). I get an error saying “SQL logic error or missing database no such table: ditto_reps”.

I have also tried choosing Overwrite Google Drive, and that has the same result. I have also tried restarting Strip.

How do I resolve this problem?


#2

Hello @quiquaequod

Do you synchronize via Google Drive any other instances of STRIP on other machines/devices, or do you just use Google Drive as a back up mechanism? If you are using STRIP with Google Drive on other devices, which ones are they?


#3

Hi @developernotes,

I use Strip on numerous devices, so Google Drive is for cross-device synchronisation rather than just backup. Apart from the Windows PC, it’s on a Nexus 4, Nexus 7, iPad, and iPhone.

I haven’t tried synchronising on the other devices since I encountered this problem on the PC.


#4

Hello @quiquaequod

Thank you for the additional details. Could you log in to Google Drive and delete the strip.db file directly? Once you have done that, could you resync from another device to Google Drive, then perform a restore operation on STRIP for Windows?


#5

Hi @developernotes,

The problem with that plan is that I’ve made several changes to the entries in the Windows STRIP, which is what I was trying to sync back to Google Drive, so I’d lose them if I did this. Is there an alternative? How about if I do an export first and then do what you say, and then import again afterwards, followed by another sync? Would that be OK? I’ve never done an export/import before…


#6

Hi @quiquaequod

Ok, in that case you could still delete the strip.db file on Google Drive, then attempt to perform an overwrite operation from STRIP for Windows to Google Drive. Once you’ve completed that, you could then sync your other devices with Google Drive to merge any data on your other remote instances with the new data on STRIP for Windows. Finally, you could then switch back to a sync mode in STRIP for Windows.


#7

Hi @developernotes, that worked a treat! Thanks very much :smile: Have a good weekend!


#8

Hi @quiquaequod

Thanks for getting back to us so quickly, we are glad to hear that has resolved the issue. Take care!