Failure in syncing to Google Drive--HTTPStatus error 401


#1

Starting yesterday, I lost my ability to sync Strip to Google Drive with the following error:

The operation couldn’t be completed. (com.google.HTTPStatus error 401.) (null)

I tried ordinary sync-ing and then I tried to overwrite sync and I kept getting the same error. I’ve tried restarting Codebook and my Mac (I’m running Codebook 3.0.13 in OS X 10.11.6 El Capitan on a MacBook Pro). I tried deleting my strip.db file (35 MB) from my Zetetic folder in Google Drive, but I still got the same error. Can someone help me figure out what the problem is that is keeping me from being able to sync?

I switched to Google Drive from Dropbox when I was struggling with getting the Dropbox sync to work. It seemed to hang every other time with Dropbox, but it’s been fine with Google Drive for a few months up to now. I don’t know if this makes a difference, but I am in China and connect to cloud services via a VPN (sometimes two).

[I do wish Zetetic could somehow get Sync-ing to be quicker and more reliable for Strip. It almost makes me want to go back to SplashID. I believe Strip’s security is better, but syncing was so much more pleasant with SplashID].


#2

Hi @Newton991 thanks for sticking with us and sorry for the issues with sync. We got an update together as fast as we could yesterday to solve the error 401 problem, you can grab it here:

Thanks also for the feedback—better sync is on the road map!