TouchID Problem


#1

I am using the current version of the STRIP iOS app for iPhone on iOS 9.1. I keep enabling the Touch ID login feature under the login settings and it does work for a while but will then revert to being turned off in the settings. Screen shot below. Its driving me crazy. Any ideas?


#2

Hi @tonester,
Sorry for the troubles with Touch ID. We’re aware of the issue and a fix is on the way in our upcoming feature release.


#3

I’ve experienced this same issue within the latest Codebook release on an iPhone 6S+ 128GB running now iOS 9.2. This evening my device spontaneously lost the ability to use TouchID within Codebook. I tried disabling and renabling, as well as force closing the app from the multitasking menu. Neither succeeded, so I rebooted my device (that is, turned it off then back on again; thanks Apple) at which point it functioned properly again (for now)…


#4

Hi @phobos512 that’s interesting—what error message were you getting from Touch ID right before a reboot fixed the problem? If there was a error number in the message that would be helpful. Thanks!


#5

I was getting no message of any kind - when opening the app it just would
put the cursor in the login passcode window and no TouchID window would pop
up.


#6

I have a similar situation. I’m using an iPhone 6 Plus 128GB running iOS 9.2 and Codebook 3.0.1 (updated on 1/4). I’m sure Touch ID worked after the update to v3.0.1 because I used it many times. On 1/6/2016 I took my phone to the Genius Bar to get the camera replaced (recall) and had to turn off my phone’s password (this erased my Wallet credit cards). After I got the phone back I reassigned the phone’s PIN and my wallet items. I’m not sure if Codebook was broken immediately or not because I can’t remember if I used it on 1/6. However on 1/7, I tried to use it and received the following popup message…

“Touch ID Unavailable
STRIP is unable to lookup your key using Touch ID. Please login to STRIP and visit Settings tab > Login Settings to reenable this feature. Dismiss”

When I press “Dismiss”, the keyboard pops up for about 1/2 a second and then the program crashes. I’ve tried rebooting the phone, but that hasn’t fixed it. I’m unable to type my password to get into Codebook.

I sent an email to tech support before I posted here. Hope this is helpful. Here’s my info…
iPhone 6 Plus 128 GB running iOS 9.2
Codebook v3.0.1
Ticket #105265


#7

Hi @BobbyD93,

Sorry about that, the Touch ID error occurred because the system’s keychain was reset at the Genius Bar, and then a crash occurs after that error message is dismissed, due to a bug. Thus, you keep landing in the same spot because the preference remains selected to prompt you.

Do you have your data backed up via sync to Dropbox, Google Drive, or Desktop WiFi? If so I think we could get you back in business by removing the app from your device, installing it fresh, and restoring your data via sync.

If you don’t have your data backed up via sync I think our next option is to get you on our TestFlight external beta testing list and have you try the beta we’re testing right now to fix this. If so, please email us at support@zetetic.net or drop us a private message here and let us know what email address to use.


#8

William,
Thanks for the reply. I managed to fix it without having to restore. The fix for me was to put my finger on the fingerprint reader and then open the app. I never lifted my finger from the reader. While leaving my finger on the reader I pressed “Dismiss” and the keyboard popped up and the app did not crash. I was able to log in with the password, turn off the Touch ID login method, close/open the program, and turn back on the Touch ID login method. It works like it should now! Hope this helps.
Thanks,
Bobby


#9

@BobbyD93 Excellent, that’s a great tip for dismissing the prompt and resetting the feature, thanks for sharing.