Unable to sync using new method

Ever since Codebook switched over to the new sync key method I have been unable to sync my phone. I tried deleting all traces of my sync data on google drive and on dropbox and starting over and now it gets as far as syncing the folders accross. I downloaded a trial of codebook for windows to try syncing over Wifi, but that also has the same effect. The problem is that right now my phone has the only copy of my passwords, and I need to move them over to a new phone (not to mention backing it up).

Any help is appreciated.

Hey @TheBloke

Thanks very much for using Codebook and reaching out, although I’m very sorry to hear about the trouble attempting to sync your Codebook data using Codebook 4.

Could you please try running an Integrity Check on the device where your data isn’t showing up on and see if it reports any issues? Integrity Check can be found under File menu > Integrity Check on the Desktop platforms and Settings > Integrity Check on the mobile platforms.

Would you please write into our support so we can assist.

Please provide these additional details when writing in:

  • What device(s) and platform(s) you’re using Codebook on
  • What cloud service you’re attempting to sync through
  • The results of running in the Integrity Check suggested above
  • If you receive any error messages when syncing and what they say



The device with all the passwords on is a Samsung Galaxy s5 running Android 7.1.2.

Other devices include an iPad on 9.3.5, an iPhone 6 on 13.3.1, and a PC on Windows 10 Home version 1909.

On the iPads (out of date) database the integrity check found issues: 4 fields missing a label have been labelled unknown.

No problems found with the integrity check on the iPhone when it only had the folders synced as mentioned before.

Its worth mentioning that on the iPad, since you switched to the new version I have been unable to authorise the google drive account without the app crashing.

While writing this I have just managed to use dropbox to sync from the iPad to other devices. After synced all the other devices to this version, I then went back and synced the Samsung Galaxy over dropbox, and then once again synced all the other devices. This time the Samsung Galaxy must have been able to sync properly as now it appears that all the devices have a matching amount of Records.

This appears to have somewhat solved the issue, although I’m not sure how.



Glad to hear you were able to get sync to work via Dropbox, although we’d like to assist you get Google Drive fixed up if that’s what you prefer.

I did just run through some testing on an iPad running 9.3 and wasn’t able to reproduce it crashing (i.e. was able to authorize/link my GD account). Do you happen to have the Google Drive App installed on the iPad device where the crash was occurring? We have seen occasional issues when this is the case (The Google Drive API which is used within Codebook uses a similar token/authentication strategy to the Google Drive App).

I’d like to investigate the crash further and have some additional follow up questions to help me try to reproduce it:

  • What version of Codebook are you running on your iPad (this can found at the top of the Settings screen within Codebook)?
  • Does it crash as soon as you tap the “Authorize” row? or after filling in your credentials and “Allowing” Codebook access?

For getting you back up and running with Google Drive sync between your devices, would you mind please reaching out to our support so I can work with you to further troubleshoot the issue?