Cannot set master password on MacBook and cannot sync


#1

We recently had to reset the master password on the iPhone strip app and the desktop application. We had only stored 2 passwords, so that is not the problem. But on the desktop, it will not let us set the master password (it continually asks us to confirm the master password, and after doing so, asks again). Also on the iPhone, it does not recognize the local area network (could this second problem be because the desktop is not open? So first, how do we fix the desktop app master password process and second how do ewe get sync to work.


#2

Hello @DeborahBurger

This sounds like problems with the App Store we’ve seen before, I think the best thing to do is a more thorough reset and cleaning so App Store can install it fresh:

  • In Finder, Go To Folder ~/Library/Containers, delete net.zetetic.Strip.mac, and empty the Trash
  • Go to the Applications folder, delete STRIP, and empty the Trash
  • Launch the App Store app, go to the Store menu, select Sign Out
  • Reboot your Mac (I know, this is annoying, I’m sorry)
  • Launch the App Store app, select Purchases, and click the Install button for STRIP

Please let us know if that helps! Also, if the problem persists, I’m curious what happens if you set and confirm a really simple password like 123. Does that also fail? Also, out of curiosity, did you make your purchase of STRIP for OS X through the Mac App Store, or through our online store? Once you get the master password reset to match STRIP for iOS, we have put together instructions for setting up sync here, could you give that a shot and let us know your results? Thanks!


#3

I have the same problem on my Macbook. The app will not let me set a master password. It just keeps asking me to re-type my master password. After four or so tries, it finally says the password doesn’t match. After this experience, I tried your idea of a super simple password of 123 and this also failed. I then tried your advice about deleting the zetetic folder in the Library/Containers folder, uninstalling the app, signing out of the app store, rebooting, signing back into the app store and then reinstalling the app. Same issue remains. Except this time it never gives the error that the passwords do not match. It only keeps asking you to re-enter your master password over and over.


#4

It sounds like we have a bug here, but I’m not sure what it is just yet. Installing the application new from the Mac App Store isn’t presenting me with any problems at the moment. Sorry for the trouble, we’re investigating!


#5

@William_Hartwell, @DeborahBurger, I’ve reproduced the bug and I have a work-around for the time being.

The Bug

On a new install, enter your password at the prompt, click on “Set Password” button with your mouse pointer. The app prompts you to type it again, type it in and click on the “Set Password” button with your mouse again, and you’re stuck in the confirm step.

The Work-Around

When setting the master password and confirming, don’t click the Set Password button with your mouse. When you are done typing your password, just hit the enter/return key and all will be well.

The Fix

We should have a patch release out soon and we’ll update this post as soon as it’s available.

Testing initial setup is part of our pre-release checklist for testing updates, but we tend to be very keyboard-oriented at Zetetic so we didn’t catch this one. Sorry about that! I’ve added a note to check the function of the “Set Password” button specifically for future updates.


#6

Thank you. This worked. Much appreciated.