Can't sync Windows app

Have used Codebook on my iPhone for years, have never had a problem syncing to my backup in dropbox. Installed the Windows version and can not sync the Windows version to my iOS version.

I use the QRcode to transfer my sync key from my phone to my computer. When I tried to sync on my computer, I get the following error message: “Another cliet is synchronizing, please try again when it completes.” Trying to sync on my phone at this point produces a similar message.

I renamed the Zetetic folder in dropbox, sync’ed from my phone (to recreate the folder), looked at the folder in dropbox and noticed that there is a “sync” file with “… conflicted copy …” in the file name.

Tried to sync again on my computer, and got the same error message as before.

Hey @plr

Thank you very much for using Codebook and posting to the discussion forum, although I’m sorry to hear about the trouble when syncing.

What is the name of the file which is listed as conflicted? Is it the sync.lock file? If so would you please delete that file (and any files named sync.lock within that Shards folder within the Zetetic folder in Dropbox). After deleting this file, please re-try syncing from your Windows machine, then from your iOS device. Does it go through this time? Is the sync.lock file properly deleted after completing these operations?

Let me know the results. Thanks!

Hi mmoore,

Trying this again because I got an error message the first time I tried to reply to your email (this is not inspiring confidence in Zetetic) …

I renamed the Zetetic folder in Dropbox, then ran Sync from the iOS app, and it created the files shown in the attached snapshot shown on the left in the attached image.

I then deleted the two sync.lock files, and did a sync from the Windows app, which worked without any errors, but it still left a sync.lock file as well as to other “conflicted” files in the Dropbox folder (see the snapshot shown on the right of the attached image).

From there, I tried sync-ing again from the iOS app, and got an error saying that an old sync.lock file was found, but that it had been deleted so try re-sync-ing again. I tried re-sync-ing, and got a different error message.

I renamed the Zetetic folder again, did a sync from the iOS app. That worked, but when I tried to do another sync from the iOS app I get another error message.



Thanks for the response and further details. It seems like something has gotten out of order with your sync states. What I’d like to have you do is perform an overwrite operation from your Windows device and then perform a Merge from your iOS device. For these following steps, please refer to this post for instructions on how to enable the Sync Operations to use in these steps:

  1. Perform an overwrite operation to Google Drive from your Windows machine.
  2. Perform a merge operation with Google Drive from your iOS device.
  3. Perform a standaard sync with Google drive from your Windows machine and confirm that a conflicted metadata file and duplicate sync.lock file aren’t created.

Let me know the results. Thanks!