Codebook Ending Support for macOS 10.12 through 10.14

Throughout the history of Codebook we’ve tried our best to support as many older versions of macOS (known previously as Mac OS X) as we could. Many apps these days only support the latest and greatest version of macOS, but that’s not how we roll. The current version of Codebook, 4.5.8, supports versions 10.12 through 10.15, macOS 11 Big Sur, macOS 12 Monterey, and macOS 13 Ventura. That is quite a spread, seven major operating system releases!

As proud as we’ve been to offer this level of long-term support, the time has come for us to start limiting support for older versions of macOS. Already, some features and improvements in Codebook require our customers to be using 10.15 or later [1]. There are development improvements we’d like to make that we’ve been avoiding for a long while because they require us to set the minimum supported version for Codebook to either 10.13 or 10.15. Then there’s the developer tools from Apple, specifically Xcode—the latest version of Xcode no longer supports building software for 10.12.

While we have no intention of requiring the latest release of macOS in order to run Codebook, setting the minimum supported version to macOS 10.15 Catalina seems reasonable to us. Here you can see a list of all Mac hardware that can run macOS 10.15 Catalina, with many models dating back to 2012.

The next major version of Codebook, version 5, is in the works, and will require all clients to upgrade to remain compatible with each other for sync. We think it’s best to make this change now while version 4 is still the current production release, so that any customers with Macs running an older version of macOS can continue syncing with all their copies Codebook until we release version 5.

Accordingly, the upcoming version 4.5.9 4.5.10 of Codebook for macOS will be the last version to support macOS 10.12, 10.13, and 10.14. After that, the new minimum version of Codebook for macOS in the version 4 series will be macOS 10.15 Catalina.


[1] For instance, the Google Drive sync feature requires 10.15 Catalina.