Dropbox sync problems

Hi, hope someone can help me with this:

I’m trying to sync Codebook between the Android app, and my desktop PC (windows) via dropbox. I’ve done this before (been using it for years) but only recently noticed it misbehaving.

From both devices, the sync appears to be working normally - it appears to run, does not report any errors. However test entries I create in either side, do not appear on the other (i.e. password entries from the PC do not show up on the phone, and vice versa).

In the Dropbox folder, the strip.db file shows an altered “modified” time when the PC version has synced to it, but not when Android has synced…

…so I suspect the issue is with the Android version of Codebook not playing nicely.

I have tested this by moving the strip.db file from my Zetetic folder in dropbox: when I run the “overwrite” update from the PC, a new version of the strip file appears (but still makes no difference to the Android version when I run its sync). When I delete that strip file from Dropbox, and run sync on the Android, again it appears to run normally - but no new Strip file appears on dropbox, and no new file in the “shards” folder either.

It’s beaten me! Any suggestions? Thanks!


Thanks for using Codebook and reaching out.

It sounds as if you may be using Codebook 3 on your Windows machine and Codebook 4 on your Android device.

Codebook 3 won’t be able to sync with Codebook 4.

Please update Codebook for Windows to Codebook 4: Updating to the Latest Version

Once Codebook for Windows is updated to the latest version, you can follow these steps to import your Sync Key from Android into Windows: https://www.zetetic.net/codebook/documentation/sync-setup-help/?platform=windows (under “If you have already created a Sync Key in another copy of Codebook”).

After the Sync Key is imported into Windows, attempt to sync again.

Let me know the results. Thanks!

Brilliant, thank you so much for the quick response.

You were right, updating the version on the PC has fixed the problem, the sync key update worked perfectly, I’ve checked it and it’s now syncing correctly in both directions.

thanks again


Excellent news. Glad I could help.

Please feel free to reach out again if you have any further questions, issues, or feedback.

Have a nice day!