Updating to the Latest Version


#1

Backup First

Backing up Codebook before you upgrade, especially a major upgrade, is always a good idea.

Android

  • Launch the Google Play or Amazon AppStore app on your device
  • The app should check for updates automatically

iOS

  • Launch the App Store app on your device
  • Tap on the Updates tab, scroll to Codebook
  • Alternatively, visit this link for Codebook (for the legacy iPad-only version click here)

Windows

macOS

If you purchased Codebook (or STRIP) in the Mac App Store:

  • Visit this link on your Mac
  • Click the “View in the Mac App Store” button
  • It will launch the App Store app and display the Codebook page
  • Click the Install or Update button below the Codebook icon
  • When installation completes click the Open button, or launch Codebook from Applications or Spotlight

If you purchased Codebook (or STRIP) from Zetetic directly:

  • Download the update
  • Unzip the file, drag Codebook to your Mac’s Applications folder
  • When prompted, choose to Replace the existing application
  • Launch Codebook from Applications or Spotlight

Important Note: If an update is not available, please verify that you are running Codebook and not the older STRIP or Strip Sync program, which is no longer supported.


Lost (disappeared) data: complete rows of data are gone - in all entries, always the same row
Schema Mismatch Error on Sync
Codebook's New Icons and Style Update
STRIP download link broken
#2

I updated Strip/Codebook on my PC without a problem. However on the Android phone, in the Play Store, Codebook says it is already installed. When I launch it STRIP still appears and rejects my password, which the PC version accepted.


#3

Hello @LDCR

Are you launching Codebook from the new icon? Would you try restarting your device and seeing if that addresses the issue? Some Android desktop managers incorrectly cache application icons, if that is the case you may need to drag the new icon onto your desktop.


#4

Restarted the phone but that made no difference. I have now uninstalled strip. But when I launched the Play Store to install Codebook, it wanted to charge me again.

Chris

Sent from iPad. Please excuse typos.


#5

Hello @LDCR

You will need to be logged into the Google Play store with the original account used when it was originally purchased. Previously purchases of STRIP for Android will upgrade to Codebook for Android at no additional cost. Can you check your login account within Google Play?


#6

Still cannot get it to upgrade on the Sony/Android without paying again.

On the iPad, it upgraded seamlessly without any problem.

On the iPhone, I get as far as the Codebook entry in the App Store which has he Codebook icon but the name Strip. I press the UPDATE button and it appears to start the download the stops and reverts to UPDATE. Tried it several times with the same result.

Would be grateful for help.

Nevertheless I am pleased with your new name and new features, particularly the Favorites feature, which I had suggested.

Chris

Sent from iPad. Please excuse typos.


#7

Nick,

Just checked and indeed I am using the same userid on Play Store.

Kind regards

Chris


#8

Typos corrected below.

Chris


#9

Hello @LDCR

Unfortunately we do not have the ability to check further into the status of your account as to why you would be receiving that message. We have verified others are able to successfully update at no additional cost within Google Play. Could you reach out to Google Play Support to see if they can provide some additional help with regard to your account? Thanks!


#10

OK Nick. Will do.

Can you shed any light on the iPhone issue below? I have highlighted it.

Kind regards

Chris


#11

Hi @LDCR

That sounds like there may be an issue with caching within your iOS App Store app. Could you launch the iOS App Store and then tap on any one specific tab bar icon 10 time? That should cause the screen to flash quickly and should reset the local cache. Could you then try to download the update?


#12

Nick

Thanks for all your help.

Android: I have now worked out why the Google Play had no record of my having bought Strip. I had bought it on the Amazon App Store. It has a record of my purchase. Strip is there but Codebook does not appear to be, unless I am looking in the wrong way. I can download Strip again, but obviously that does not help. Can I get Codebook from Amazon or do I have to start over in the Google Play Store?

iPhone: Tried your suggestion below but nothing happened. Not sure that I am correctly interpreting your instruction, tap on any one specific tab bar icon 10 time[s]. Which are the tab bar icons?

Also, should I uninstall Strip on the iPhone?

Thanks

Chris


#13

Hello @LDCR

That explains the Android situation! Codebook for Android has been submitted to the Amazon App Store, we are awaiting distribution over their CDN and hope it is available soon.

The tab bar icons within the iOS app store app are “Featured”, “Top Charts”, “Explore”, “Search”, and “Updates”. You can tap on any one of those 10 times and your screen should refresh, cleaning the app store local cache.


#14

When I updated to code book on my iPhone I no longer see the option to sync from my google drive as I have been doing with STRIP. Only Dropbox is an option to sync.


#15

Hello @kylebradshaw

Can you make sure you have upgraded STRIP to the new Codebook? The screenshot you posted above appears to be our old version of Codebook, sorry for the confusion.


#16

Ok thank you that ended up being the solution


#17

Hello @kylebradshaw

Great, I’m glad to hear that resolved the issue. Thanks for the quick reply!


#18

Nick

I now have Codebook working properly on iPad, and iPhone (having paid for it twice).

Still having a problem with the Android version from the Amazon Appstore. Just went to the Appstore and Codebook appears there. It recognises that I have bought Strip and allows me to open it from the Appstore, but when I do, Strip appears, not Codebook. It asks for my master password twice and then opens an empty vault. Should I have uninstalled Strip? Or is it not really there yet on the Amazon Appstore?

Kind regards

Chris


#19

Amazon just informed me that Codebook update was available. Downloaded, installed, synced and now operating. Problem solved.


Codebook for OS X 3.0.2 Released
#20

Hello @LDCR

Thank you for getting back to us, we are glad to hear everything is working well for you now.