iOS Sync failure - sync lock found that's older than two minutes

Trying to sync on an iOS 13.3 device with Codebook 4.02 and keep getting the “sync lock found that’s older than two minutes” error and sync fails. No other devices are syncing. Been trying for 24 hours now, same problem. Was working fine before this occurred.

Hi @wibblewibble

Sorry about the trouble you are experiencing. Are you syncing Codebook for iOS with a cloud service such as Dropbox, or Google Drive, or are you syncing to Codebook on the desktop using local WiFi?

Google Drive.
Now resolved once I’d loaded up Codebook on the PC that must have been hogging the lock.

Hello @wibblewibble

Thank you for the update, we are happy to hear everything is working properly for you now!

Alas this problem is coming up again now, and at present I cannot resolve it. It’s syncing iOS and 3 PCs with Google Drive.
And now waited a bit of time and that message has gone but now getting the “sync lock found that’s older than 2 minutes” message, which again I can’t clear.

Hi @wibblewibble

I’m sorry to hear about the trouble. Can you tell us about the specific sync scenario that is causing an issue?

Hi, I fixed it again. This time by going into Google Drive and deleting about 10 sync lock files. It then worked.

FYI This has only started happening since late December, after the recent big update.

Hi @wibblewibble

Thanks for letting us know. Would you mind reaching out to us at, we’d like to dig into this a bit further. Thanks!

Hello Zetetic Support
Seems I am having the same issue. Sync lock found that’s older than two minutes.
The issue is only with iOS version, neither Windows nor Android do have this. These two are syncing fine any time I am starting it.
the only thing I can see is that the iOS version is 4.0.4 (870), while Windows 10 carries 4.1.6 and Android 4.1.0. Not sure this has an impact.
As I have now read about the fix wibblewibble has applied, I did the same. Found five (5) sync loc files, the oldest dating back to May 20th 2020, three from today (yes, I’ve made several attempts to sync with iOS version)
Any idea what I may have done wrong so these sync loc files were not deleted?
Thanks for your support and feedback.

Hey @diaro56

Thanks for using Codebook and posting to the discussion forum, although I’m sorry that you experienced this issue as well. Just to confirm, this is occurring with Google Drive sync correct?

We believe we’ve identified an edge case issue which could be causing the sync.lock file to not be properly deleted (as it should) when syncing an iOS device with Google Drive.

Are you able to manually delete the sync.lock files from Google Drive when using a web browser and does that allow you to successfully sync your iOS device with Google Drive?

The next beta version of Codebook (4.2.0) will include a fix for this issue. Let me know if you’d like to beta test it to ensure that it resolves the issue on your end. Thanks!

Hello there

Yes, have deleted five sync-loc files … so it worked… have reported this in the end of my input.

Your feedback however is providing the information I am looking for.

Thanks a lot